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 Chapter 0  About Jedit X

Introduction

Jedit was first developed in 1995 as the text editing module for our Jterm 
communication software. At the time it was released as a freeware editor to great 
acclaim. 

In November 1997, we released Jedit 2.0, which combined macro and AppleScript 
support with OS 8 compatibility. Because of the added performance of the software, 
Jedit 2.0 made the switch to shareware.

In April 1999, we released Jedit 3.0 as a text editor for the multimedia age, complete 
with support for multiple styles, multiple fonts, sounds, images, QuickTime, HTML 
auto-coloring, and other features. 

Then, in October 2000, we released Jedit4.0 for the new operating system Mac OS X. 
Jedit 4.0 ran natively in OS X as a Carbon application and offered word processor-
class expressive capabilities with features such as left, right and center alignment, 
variable line spacing, and left/right indents. 

Finally, the release of Jedit X was the result of re-building the software entirely from 
scratch in Cocoa to best take advantage OS X’s capabilities. The result is a text editing 
environment offering a multitude of advantages to the user. Some of these are:  

・Unicode-Based Multilanguage Support
Jedit X is based on Unicode, which allows the same document to contain multiple 
character sets, including right-to-left languages such as Arabic. This also provides 
an excellent environment for editing Unicode based documents like XML or 
XHTML. 

・OpenType Hiragino Support, with Over 20,000 Characters
Jedit X supports the Hiragino typeface and its 20,000 characters contained in JIS 
X0123 (JIS 3&4). 

・Sleek Aqua Interface
Jedit X makes full use of Mac OS X’s Aqua for a simple, elegant user interface.



・Plays Well with Other Cocoa Applications
Jedit X is highly interactive with other Cocoa programs. For example, pasting from 
Safari to Jedit X carries over formatting, image and even link information. 

・Utilizes Cocoa’s NSTextView Text Engine
Jedit X makes use of Cocoa’s built-in NSTextView text engine, which provides 
high-performance text-editing features like back tabs, center tabs, kerning, ligature, 
superscript, and subscript. Jedit X also offers its own capabilities, including line 
numbering, invisible character display, custom wordwrapping, split windows, and 
other 

・Supports a Wide Array of Document Types
Jedit X can read Plain Text, Rich Text Format (RTF), Rich Text Format Directory 
(RTFD), MS Word, Jedit 4, and SimpleText documents. It can also write Plain 
Text, RTF, RTFD, and MS Word documents. 

・Powerful Regular Expression Handling
Jedit X uses OniGuruma, the regular expression engine used in the object-oriented 
language Ruby. This powerful and flexible regular expression engine far surpasses 
the engine used in Jedit 4. 

・Improved Search and Replace
Search and replace has been made even more powerful and easy to use in Jedit X. 
New capabilities include faster Replace All, a handy search and replace history, 
internal processing of batch search and replace operations (up to thousands at a 
time), and search and replace from the Toolbar.

・Flexible Bookmarks
Bookmarks can be created in user-defined hierarchies to jump instantly to any 
location in the document. Bookmarks can also point to separate Jedit X documents. 

・Links to URLs, Files, Folders, and Bookmarks
Simply drag and drop URLs, files, folders, or Jedit X bookmarks to automatically 
embed links to these. 

・Customizable Syntax Coloring
Jedit X supports freely customizable syntax coloring for HMTL and other 
programming languages. Built-in support includes C, CSS, HTML, JavaScript, 
Latex, Perl, PHP, and URLs, but these can be infinitely expanded by the user. 

・Easy Customization of Menu Shortcuts and Key Commands
Users can freely customize menu shortcuts and key commands with Key Bindings 



in Preferences. Jedit X also supports  switching ￥ with backslashes on JIS 
keyboards to enable one-stroke input without the need for special options. 

・Powerfully Flexible Toolbar
Users can freely add or remove different functions from the Toolbar, including 
Search Panel, Search Window, Replace Window, Font Menu, Font Panel, Size 
Menu, Color Menu, Color Panel, Document Info, Bookmarks, Bookmark 
Selection, Position, kerning, Baseline, Display, Document Width, Save, and Print. 

・Powerful Sorting
Sorting may be performed according to either the roman alphabet or Japanese. 
Japanese sorting may be performed according to the “a-i-u-e-o” order instead of the 
Unicode order by a function that automatically converts kanji to hiragana for 
sorting. Word delimiters can also be defined with regular expressions, so sorting is 
possible on desired positions within lines in CSV files. 

・Automatic Detection of Japanese, Chinese, and Korean Encodings 
Jedit X can automatically detect the Japanese encodings 
ISO-2022-JP,  EUC-JP, Shift-JIS, UTF-8, and UTF-16, as well as Chinese 
(simplified or traditional) or Korean encodings. 

・Inline Automatic Spell-Checking  
Jedit X can check spelling as you type in any of eight languages, including English, 
French, or Italian. Of course, you can also save checking for after the document is 
finished. 

・Fully AppleScriptable 
You can describe almost every text manipulation with AppleScript. 
Your script files can be registered at the macro/context menu as your original 
commands. 

・Automatic Backup for Data Recovery
Jedit X saves your document automatically as you work, so you can recover it even 
if the program or OS X crashes just before you complete your masterpiece. 

We are continually improving Jedit X to make it even better for our users. All kinds of 
feedback, including bug reports or suggestions for improvement, are welcome at 
support@artman21.co.jp.

September, 2004
Satoshi Matsumoto, Artman 21





Copyright, Use, and Distribution

(1) Copyright for Jedit X resides with Satoshi Matsumoto (satoshi@artman21.co.jp). 
Jedit X may not be altered in part or in whole without permission of the copyright 
owner. 

(2) Jedit X is shareware. Use is free for a twenty day trial period, after which a license 
fee must be paid. Click this link for online user registration: 
 https://www.artman21.net/shop/ 

(3) The copyright holder is in no way responsible for damage of any kind incurred 
through use of Jedit X. Further, usage rights gained through registration are not 
transferrable to third parties. 

(4) Jedit X may be freely distributed through the Internet or other media for non-profit 
uses alone. However, the software may not be altered in any way. Written permission 
must be obtained in advance from the copyright owner before including Jedit X on any 
CD-ROMs or other media for distribution or as part of any software bundles. 

(5) The copyright for OniGuruma, the regular expression engine used in Jedit X, 
belongs to K. Kosako (kosako@sofnec.co.jp). OgreKit, the Cocoa framework for 
OniGuruma, belongs to Isao Sonobe (sonobe@gauge.scphys.kyoto-u.ac.jp). 



User Support

We welcome all questions, requests, and bug reports for Jedit X. Contact information 
is as follows:

Artman21 User Support
Email:  support@artman21.co.jp 
TEL/FAX  +81-(0)466-24-1028

16-11 Minami Fujisawa, Fujisawa-shi, Kanagawa-ken Japan 251-0055

The most recent Jedit X release can be found at the following link. 

 http://www.artman21.net/product/JeditX/index.html 

Support is available at the following address if you forget your registration code, or if 
you want to change your registered email address. 

 http://support.artman21.co.jp/  
 
 
 

 



Chapter 1  Installation and Launching

1.1 Compatibility 

Jedit X can run under Mac OS X 10.3 (Panther) or later. 
Please use Jedit4.0 for Classic environment or 10.2 or earlier. 

1.2 Installation

Jedit X can be downloaded in compressed form from the following URL:

 http://www.artman21.net/product/JeditX/index.html 
 

Once downloaded, the following icon will appear on the desktop. 

Double-click this icon to display the following window:

To complete installation, simply drag the Jedit X icon to your Applications folder. 





1.3 Launching Jedit X 

The following dialog appears when you start up an unregistered copy of Jedit X. This 
window will no longer appear once you have registered the program. 

Click Use on Trial Basis to use the program without registering it. There is a built-in delay 
of several seconds before the document window appears. 

The following message appears when the trial period of 20 days ends: 

Aside from the above message, program functionality will not be limited if you continue to 
use it without registering past the 20 day time period. We are sorry for any inconvenience 
this may cause, but it is necessary to maintain the program as a viable shareware business. 

You can click Purchase License to register the program online. Payments by credit card or 
bank transfer (within Japan) are accepted. 

1.4 Registering Licenses



Within several days of registering, you will receive a User ID and Registration key by email. 
Open Jedit X>License... and press the button "Enter RegistrationKey" to input these and 
register the program. Be sure to select "Jedit X" as Product Name and copy the 
information carefully, then click OK button.

When inputting your User ID and Registration Key, make sure they are exactly as sent to 
you by email, with no additional spaces. Any errors in input will result in failed registration. 

Once the program is registered, you will proceed straight to a document window when 
launching the program. 

1.5 Checking for Updates

Select Jedit X>Check for Updates... to see if your version of Jedit X is the most recent. If 
it is, this dialog appears:



If there is a more recent version, the following dialog appears:

Click Download to download the most recent version. 

You must be connected to the Internet to check for recent updates. Also, sometimes firewalls 
will prevent checking from occurring. 

Finally, if you turn the Check for updates every 10 days option on in the General tab of 
Preferences, this process will occur automatically every 10 days. 



Chapter 2  Preferences

2.1 Default Preferences File

All preferences are saved in the default Preferences file, jp.co.artman21.JeditX.plist, 
which is located at
 

~/Library/Preferences/jp.co.artman21.JeditX.plist

Ordinarily, there is no reason to use this file directly, but it can be used in the following 
situations: 

Restoring all preferences to their default values
To restore all preferences to their default values, close Jedit X and then move this file 
to the Trash. When you start Jedit X again, all preferences will be reset. 

Transfer preferences to another computer
To transfer your preferences to another computer, simply copy the Preferences file to 
the Preferences folder (location shown above) of the new computer. 

2.2 General

Use the General tab in Preferences to change general options about the way Jedit X 
operates. There are three types of preferences: those applied immediately, those applied 
when the next file is opened, and those applied when Jedit X is restarted. 

Enable continuous spell checking
Check this box to enable continuous (“as you type”) spell checking in the next 
document opened. To enable continuous checking in documents which are already 
open, select Edit>Spelling>Check Spelling as You Type.

Enable "smart text editing”
“Smart text editing” makes it more convenient to make changes. For example, when 
two spaces appear after you delete a word, this option automatically deletes the extra 
space. Or, if you paste a word next to another and there is no space in between, this 
option automatically inserts the necessary space. 



Enable Undo
Select this option to enable Undo and Redo in the Edit menu. This option is usually 
turned on.

Don’t clear Undo when saving
Select this option to allow undoes past document saves. If this option is not checked, 
then once a document is saved (File>Save) you will not be able to perform undoes past 
the stage at which it was saved. 

Scroll  Speed
Select Slow, Normal, or Fast scroll speeds when the scroll button is pressed. 

Margin for document end
Select None, 1/4 page, or 1/2 page  margins for scroll up when a new line was added 
at the end of document.. 

Ignore rich text commands in RTF files
Use this option when you want to import RTF files as plain text, without executing the 
commands included in the RTF files. 

Load these documents as Plain Text
Select this option to load Jedit 4 or SimpleText documents as plain text with no style or 
font information. 

Text-Smoothing (AntiAliasing)
Select this option to smooth out (anti-alias) text displayed. Turn this option off if small 
characters become blurry when smoothed. 

Swap ‘￥’ input for backslash ‘\’
On Japanese JIS keyboards, the \ (backslash) character can only be input by pressing 
Option+¥. Select this option to input the backslash automatically when ￥ is pressed. 
When this option is enabled, input the ￥ character by pressing Option+¥. This option 
is useful for those who need to input the backslash character on Japanese keyboards 
often (it is ignored on all keyboards other than Japanese JIS keyboards). 

Check for updates every 10 days
Use this option to have Jedit X check for updated versions of the program over the 
Internet every 10 days. When there is a new version of Jedit X available, a dialog box 
for downloading will be displayed. 

Set Jedit X a default ftp-editor
Press this button to register Jedit X as a protocol helper for ftp-editor in the Internet 
Config system. You can use Jedit X as an external editor for ftp application Interarchy.



You may see or edit settings of the Internet Config system with Classic mode Apple 
Menu>Control Panel>Internet.

Number of Recent Items
Determine the number of files shown in File>Open Recent. 

At Start-up
Select from among Open a New Document, Open Last Documents, and Do 
Nothing when launching Jedit X. If Open Last Documents is selected, all documents 
opened the last time the program was shut down will be re-opened. 

Carbon like Drag & Drop start timing
In Cocoa applications, you must hold the mouse button down for about 0.3 seconds 
before starting a drag & drop. Use this option for those who want to start dragging 
without the delay like in Carbon applications.

Ruler Character Unit
This option allows you to select the font upon which the ruler markings are based 
when the ruler marking unit is Characters. For example, if you select Hiragino Kaku 
Gothic  Pro W3 14 pt. with a base character of m, then the ruler markings will be 
spaced according to the size of full-width characters in that font. If the font used is full-
width Hiragino Kaku Gothic Pro W3 14, then the characters will line up perfectly with 
the ruler markings, but if a different font is used they will not. In order for both half-
width and full-width characters to line up with ruler markings, you must select a 
monospaced (fixed pitch) font such as Osaka Regular Mono. Proportional fonts (such 
as Hiragino Kaku Gothic) will match up with the ruler markings for full-width 
characters, but not for half-width characters. This is because the width of half-width 
characters depends on the individual character (m takes up more space than n).

Date Format
Use this setting to determine the format for dates inserted by Jedit X when you select 
Edit>Date Stamp.  When System Date Format or System Short Date Format are 
selected, the date format is determined by the setting selected in 
International>Formats in System Preferences. 

Time Format
Use this setting to determine the format for times inserted by Jedit X when you select 
Edit>Time Stamp. When System Date Format is selected, the time format is 
determined by the setting selected in International>Formats in System Preferences. 

Insertion Pointer Shape
Select cursor shape from among Normal, Block, and Cross. 

Simple Revert without Dialog



When this option is selected, no dialog will appear before reverting to the last saved 
state of your document after selecting File>Revert. Turn this option off to show a 
dialog that will give the option of changing encodings or other options. 

Activate All Suppressed Alerts
This option shows the following alerts, even if you have selected the option not to 
show them again.
・Alert when changing Rich Text to Plain Text. 
・Alert when the encoding is detected to be different than the default encoding. 



2.3 New Document

The New Document tab in Preferences allows you to determine the properties of new 
documents created when you select File>New. Some of these properties are also 
applied when opening documents (Jedit 4, SimpleText, Plain Text, RTF, and RTFD 
documents) created in other programs. In this case, properties determined by Jedit X 
are those not already specified by the document itself. 

These options do not affect documents that have already been opened or created. To 
change properties for these documents, use the View or Format menus to change them 
directly. 

2.3.1 View

Wrap to Window/Wrap to Page
Select whether new documents wrap to window (window layout view) or to page 
(page layout view). For details, see 4.1 Window Display Mode and Page Display 
Mode.

Zoom
Select the zoom factor for new documents.

Show Toolbar
Select whether or not to show the Toolbar for new documents. This setting applies 
when opening existing documents as well. 

Window Size
Determine the window size for new documents. Select Copy from Current 
Document Window to use the size of the open document window. 

Show Text Formatting Ruler
Select whether or not to show the ruler when opening new documents. 

Ruler Unit
Select Points, Centimeters, Inches, or Characters for ruler units. When Characters 
is selected, the character and font specified in the General tab are used to set ruler 
marking width. 

Show Line/Paragraph numbers in Wide/Narrow gutter
This setting determines how line and paragraph numbers are displayed. 

Show Control Characters
Select whether or not to display the (usually invisible) control characters. Refer to 



 5.4 Control Characters to know how these characters are displayed.
 
Show Invisibles
Select whether or not to display the (usually invisible) characters for single spaces, 
nonbreaking spaces,  double byte (full-width) space, tabs, line breaks, paragraph 
breaks and page breaks. Refer to  5.5 Invisible Characters   to know how these 
characters are displayed.

2.3.2 Format

Plain Tex/Rich Text
Determine whether new documents are created as Plain Text or Rich Text files. 

Name of New Document
Determine whether new documents are automatically named Untitled+#,  [Date]-
[Time]+#, YYYY-MM-DD+#, System Short Date +# or System Long Date+#.

Document Width
Determine document width when in window display mode. When set to Follows 
Window Width, the document width changes fluidly along with the size of the 
document window, which is changed with the size box in the lower-left corner of the 
window. 

When set to Fixed Width, document width stays constant at the set width, which can be 
defined in points, centimeters, inches, or characters. When defined in characters, the 
character set as Base Character in the General tab of Preferences is used to determine 
width. 

When set to Follows Page Width, document width will match paper size selected in 
File>Page Setup... This allows the on-screen document to closely match the printed final 
product even in window display mode.

When set to Do Not Wrap Lines, document width is treated as infinitely wide, so no soft 
wrapping occurs. This setting is used for program source files. 

Wordwrapping Method
Determine what kind of wordwrapping to perform. Select Japanese Custom 
Wordwrap to follow the options selected in the Wordwrap tab. 

Tab Width
Set default tab width. When set to Characters, width will depend on the font and 
character selected as the ruler character unit on the General tab. 



Line Space
Determine the spacing between lines. You cannot decrease line spacing past the font 
height. If a line spacing smaller than the font height is set, the minimum line spacing 
value possible will be used. 

Auto-indent new lines
When this option is selected, new paragraphs (created when Return is pressed) are 
indented automatically to match the paragraph above.

Indent wrapped lines of plain text by
Wrapped line indent allows Jedit X to automatically indent lines that are soft-wrapped (when 
a new line is created because the document width is exceeded, but not when a hard line break 
is added, such as by pressing Return). This function makes lists easy to read for HTML, 
other programming documents, or any document with long lists. 

You may set the indent width. Set "0" to indent the same as the top line, input a positive 
number to make the indent deeper, or input a negative number to make the indent shallower. 

2.3.3 Font&Color

Default Fonts
Set the default fonts for new Rich Text and Plain Text documents. If you select the 
same font as that selected as the ruler character unit on the General tab, text typed will 
line up with ruler markings. 

On Mac OS X 10.4 or later, you are recommended to assign a fixed-width font, such 
as Monaco,  for plain text default font  so that multi-mega byte files will be opened 
more quickly.

Colors
Select colors for foreground, background, selection, insertion point, line number, and 
invisible characters. Click the colors to display the Color Palette, from which you can 
pick a color of your choice. 

2.3.4 Paper Layout

Set the page layout for page display mode and printing. 

Paper Margin
Set the left, right, upper, and lower margins. Headers and footers are displayed inside 
the upper and lower margins respectively, and line numbers within the left margin. 



Use Ruled Paper
Follow the steps below to make settings for ruled paper in page display mode. 
1. Select paper type from among Letter Paper, Section Paper, and Copy Paper. 
2. Set line color and thickness. 
3. Set the font upon which the ruled pattern will be based.  
4. Select a character upon which each cell size will be based. Cell size is calculated 
according to the width of the character selected. 

2.3.5 Header & Footer

Create headers and footers to be displayed in page display mode and when printed.

The Header and Footer fields are both independent text editing fields, so use them to 
input desired text. 

Click the Ruler option to show the ruler. You may also set style, alignment, and tabs, 
or use the Font menu to set font, font size, and font color. Images may also be pasted 
or dragged and dropped in. 

Aside from text or images, you may also set variables to be displayed in the headers 
and footers. The following variables may be selected from the Insert Variables popup 
menu and inserted at any position desired:  Page Number, Page Total, Current Date, 
Current Time, Document Title, File Path, User Name, Modification Date, Modification 
Time, Author, Company, Copyright, Title, Subject, Keywords and Comment.

Modification Date and Modification Time indicate the time at which the file was 
opened, but they are renewed automatically as the document is edited.

Always click Set after editing headers and footers. If you close the window without 
clicking Set, then the headers and footers will not appear in the document. Click Reset 
to begin editing the fields again. 

2.3.6 Properties

Set default document properties (Author, Company and Copyright) for new 
documents. You can change settings for individual documents from the menu 
File>Properties. (Properties are available on Mac OS X 10.4 or later.)

2.4 Encoding



Jedit X supports automatic detection of character encoding when reading Plain Text 
files. 

Default Encoding and Line Endings for Plain Text
Determine the default encoding and line endings for Plain Text files. When the desired 
encoding isn’t included in the dropdown menu, select Customize Encodings List... to 
add it. 

These defaults are used for new Plain Text files. They are also applied when automatic 
encoding detection is turned off. 

About the Four Types of Shift-JIS Encoding
There are four types of Shift-JIS encoding available (although you may need to 
customize the encoding list to see them all). 
Japanese (Shift JIS) contains the half-width alphanumeric characters, symbols, and 
katakana, along with JIS X0208 (JIS 1&2) characters.
Japanese (Mac OS) contains all of Japanese (Shift JIS) along with some Mac-
specific symbols. 
Japanese (Windows, DOS) contains all of Japanese (Shift JIS) along with some 
Windows-specific symbols. 
Japanese (Shift JIS X0213) contains all of Japanese (Shift JIS) along with kanji 
specified in JIS 3&4 for a total of 13,000 characters total. 
Japanese text created in Classic OS is encoded in Japanese (Mac OS), so this is the 
safest option among the various Shift JIS encodings.  
 
Sniff the character encoding when loading a text file
Select this option to automatically detect the encoding of text files opened.

Encoding detection is performed in the following manner:

1) If an encoding is specified in the file’s resource fork, that encoding is used 
automatically when opening the document. When there is no encoding specified, step 2 
occurs. 
2) Jedit X searches to see whether the file matches any of the candidate encodings 
selected in Select sniffers you wish to use. 
3) If only one match is found, then that encoding is used. 
4) If no matches are found, then the following dialog appears for you to select the 
encoding directly from a menu. 



5) When the document matches multiple encoding candidates, the following dialog 
appears. Select the encoding manually from the List of possible encodings. 

If you cannot find the right encoding in the list of possible encodings, choose 
"Encoding other than above items" at the bottom of the list. Then 4) dialog will appear 
and you can select the encoding from the encoding popup menu.

Alert when a sniffed encoding was different than the default
When this option is selected, the following dialog appears when the detected encoding 
differs from the default encoding. 

If the automatic encoding detection is wrong, you can change it from the encoding 
menu. When you don’t wish this dialog to appear again, select Don't show this alert 



again.

Convert ‘￥’ (0x5c)  to Unicode backslash '\' (0x005c) when Shift-JIS encoding 
group.

    Shift-JIS group Unicode
Reading ¥　0x5c → \　0x00a5
Reading ¥　0x80 → \　0x005c
Saving ¥　0x5c ← \　0x00a5
Saving ¥　0x80 ← \　0x005c

Japanese (Mac OS) uses 0x80 for the backslash, but this code is unique to this 
encoding. In general, the backslash is represented by 0x5c, so if the 0x80 is used for 
the backslash in the resource list, errors may occur. 

Therefore, turn this option on to make the following conversions automatically:
 Shift-JIS group Unicode

Reading ¥　0x5c → \　0x005c
Reading ¥　0x80 → \　0x005c
Saving ¥　0x5c ← \　0x00a5
Saving ¥　0x5c ← \　0x005c

This means that you can input both the backslash or the yen symbol in Jedit X and not 
worry about how they are saved. They will both be saved as 0x5c (the yen symbol) in 
Shift-JIS encoding group. 

Convert ‘¯’ (0x5c)  to Unicode Tilde '~' (0x005c) when Shift-JIS encoding group.

Overline mark ‘¯’ (0x5c)  is converted to unicode as below according to its encoding.

     Japanese(Mac OS) 　　　　　 ~(u+007e)
Japanese(Windows)　　　  　 ~(u+007e)
Japanese(Shift-JIS)　　　　 ‾（u+203e)
Japanese(Shift-JIS x2013)         ‾（u+203e)

 
Therefore, turn this option on to make the following conversions automatically:

     Japanese(Mac OS) 　　　　　 ~(u+007e)
Japanese(Windows)　　　  　 ~(u+007e)
Japanese(Shift-JIS)　　　　 ~(u+007e)



Japanese(Shift-JIS x2013)         ~(u+007e)

This means that the tilde and overline marks in Shift-JIS encoding group are always 
converted to unicode tilde(u+007e).

Convert FULLWIDTH TILDE  '～' (U+FF5E) to  WAVE DASH  '～' (U+301C).
FULLWIDTH TILDE  '～' (U+FF5E) sometime causes conversion error when 
converting to other encodings, such as Mac OS Japanese, because FULLWIDTH 
TILDE is mostly used in Windows world. This option enable to convert  
FULLWIDTH TILDE to WAVE DASH  '～' (U+301C) when loading documents.

Select sniffers you wish to use
Jedit X supports automatic detection of Unicode, four types of Japanese, four types of 
Korean, and seven types of Chinese encodings. Select which encodings you wish to be 
used as candidates for automatic detection. 

Keep the following in mind when selecting encodings: 
・As more candidate encodings results in greater detection time and a lower chance of 
correct detection, always use the minimum number necessary. 
・When two or more encoding of the same type are used as candidates, the program 
will not be able to narrow it down to just one. For example, if both Japanese (EUC) 
and Korean (EUC) are used, then both will match for EUC documents. 
・Both Japanese (Mac OS) and Japanese (Windows, DOS) use the same Shift-JIS 
encoding, but the line break code differs between the two. Since this can be used to 
distinguish between them, both may be selected as candidate encodings. 

2.5 Save

The Save tab offers many options related to saving documents. 

Delete backup file after saving
When closing Jedit X, the program can preserve backup files created before saving 
documents. For example, when saving the file “abcd.txt”, the backup file “abcd~.txt” 
will remain in the same directory. Turn this option on to automatically delete the 
backup file after saving. 

Save read-only files as writable
The following dialog appears when you attempt to write to a file that is read-only 
(locked). When this option is off, click Overwrite to write the file but keep its status as 
a read-only file. 



Overwrite read-only files
This option allows you to write over even locked files with no warning dialog. 
Whether or not the saved file is locked depends on the selection made for the previous 
option. 

Append “.txt” extension to Plain Text files
Turn this option on to automatically add the “.txt” extension to Plain Text files when 
saving them under a different name. 

Change file creator to ‘JEDX’
Turn this option on change the file creator property for documents to ‘JEDX’. This 
will allow RTF, RTFD, and other Jedit X documents to be represented by Jedit X’s 
own icons on the desktop. 

Enable Save menu even if the document has not been edited
Usually you cannot choose the Save menu when the document has not been edited.
Turn this option to enable the Save menu  regardless of the document editing state. 
This option may be useful when you wish to save the cursor position or the window/
page display mode without changing the document contents.

Save UTF-8 document with BOM (0xEF, 0xBB, 0xBF)
When this option is ON, 3 byte of BOM (0xEF, 0xBB, 0xBF), which identifies as 
UTF-8 document, will be saved at the top of UTF-8 file.
However, as the UTF-8 BOM is not popular yet, some applications will not 
understand the BOM and displays "???" for BOM. For such cases, please set this 
option to OFF.

Use Resource Fork for Saving Document Attributes
Rich Text documents (RTF/RTFD) save the following document attributes in the data 
fork: window size, window or page display mode, scale, read-only or writable, hyphen 
processing, paper size, and margins. 

The following attributes are saved in the resource for RTF files: header and footer 
information, view-related information, document width, document width mode (fixed, 
variable, or soft wraps), window position, selection area, scroll position, soft wrap 



indent information, wordwrap information, drawer status, tab width, bookmarks, font 
information, line spacing, ruled paper information, ruler status, toolbar status, line 
numbering status, invisible character display status, and auto-indent status. Therefore, 
if the resource fork is not used for RTF files, these attributes will not be saved. 

However, all of the attributes above are saved in the resource fork for Plain Text files, 
so if the resource fork is not used, they will not be saved.

RTF files share a universal format, so attributes saved in the data fork can be read by 
other text editors. However, information saved in the resource fork can only be read by 
Jedit X. 

If document attributes are saved in the resource fork and either opened in another editor 
or transferred to a file system that does not support resource forks, then the 
information in the resource fork will be lost. 

Save Window Attributes
Window size, window location, and scroll position/cursor location may be saved when 
windows are closed. Even if this option is enabled, if Use resource fork for saving 
document attributes is turned off, window attributes will not be saved. 

Crash Guard
Crash Guard instructs Jedit X to save the current file automatically every time a certain 
number of keystrokes are depressed in case either the computer or the program crashes. In 
this case, backup files are contained in the following location in the user directory:

~/Library/Application Support/Jedit X/backups/ 

The following dialog is displayed when Jedit X launches following a crash and there is a 
backup file:

Select Recover to restore the backup file from before the crash occurred. 



2.6 Key Bindings

Jedit X allows users to freely customize menu shortcuts and key commands. These are 
called "key bindings," and multiple sets can be defined. 

The default set of key bindings is called "System Defaults," which may not be altered. To 
add to or alter this set, first press Copy to make your own custom set of key bindings.

There are two types of key bindings, Menu Shortcuts and Key Commands. Use the tabs 
at the top of the window to switch between them. 

Menu Shortcuts
A shortcut key may be assigned to nearly any command in any main menu. These menus are 
all represented in the key bindings window. Click on a triangle to see the next level in the 
menu hierarchy. 

To modify a menu shortcut, just select it and then press Command (Apple) key plus your 
desired key binding. Press Delete to clear a key binding. 

Assign cmd+Number shortcut for Windows menu item.
Select this option to assign cmd+Number shortcut key to each Windows menu item. 
When the assigned number conflicted with other shortcut key, another number will be 
assigned.

Key Commands
The System Default Key Commands are based on the key bindings for the operating system 
itself (~/Library/KeyBindings/DefaultKeyBinding.dict).

You may assign up to three key commands for any given command, each of which may 
consist of up to two keystrokes. 

To alter a key command, double-click in one of the three cells for the command, then input 
your desired key sequence. Press Return to finish, or Delete to erase the command.

Export/Import Key Binding Sets
To export a key binding set, click Export. A save dialog will appear, so select the name and 
save location for your exported set. To import a set of previously exported key bindings, 
click Import and select the file to open. Use this function to share key binding sets between 
users or between different computers for one user. 

2.7 Find

The Find tab allows you to set various options related to find and replace.



Bring document window forward after Find
When this option is turned off, the Find panel will remain the front window after performing 
a search. Turn this option on to have the document window(s) containing the search string 
brought automatically to the front. 

Clear old find results before Find All
Search results for Find All are shown in the Find Results window. Turn this option on to 
clear previous results before displaying the results for the current search. 

Also copy selection to Replace field when "Use Selection for Find" is selected 
Turn this option on to automatically copy the selected character string into the Replace field 
when performing Find>Use Selection for Find. 

Do not share find strings with other applications
Cocoa applications can share search strings with each other. For example, you can 
automatically have a search string used in Safari carried over to Jedit X. Turn this option on 
to disallow this function. 

Suppress encoding sniffer alerts when executing multi-file search
Turn this option on to open up documents in the default encoding during multi-file searches. 
If this option is off, a dialog will appear for each file which has multiple encoding 
possibilities. 

Leave cursor in the Find field when nothing is found
Turn this option on to leave the cursor in the Find field when no matches are found for the 
search string. 

Find Result Display Font
Set the font for the Find Result window. 

Number of Recent Items
Here you may select the number of recent search or replace strings which appear in the Find 
and Replace history. 

Regular Expression

Meta-Character for Escape 
The backslash \ (ox5c) is usually used as the escape character, but some systems have 
allocated then yen symbol ¥ to the 0x5c code. Jedit X uses Unicode for internal processing, 
so there is no problem with using the backslash; however, this option should be used for 
documents produced on systems which use the yen character (if the distinction is causing 
trouble for some operation). 



Regular Expression Syntax
There are various kinds of regular expression syntaxes. Jedit X uses the Oniguruma regular 
expression engine, which uses Ruby as the the default syntax but also supports 
POSIX Basic RE, POSIX Extended RE, Emacs, grep, GNU regex, Java (Sun 
java.util.regex), and Perl. Although you may specify different syntaxes here for use in the 
Find panel, regular expression syntax as used in the Coloring tab always uses Ruby. 

'.'(any character) matches on line breaks
Turn this option on to have the period (any character) match also on line breaks. This is 
usually off, because then .* (the regular expression for any repetition of any character) 
would match on the entire document. 

Ignore empty matches
Turn this option on to ignore empty matches and go on to the next search.

Beginning of search region is not considered Beginning of Line (BOL)
Determine whether or not the beginning of the search region is handled as the beginning of 
the line.

End of search region is not considered End of Line (EOL)
Determine whether or not the end of the search region is handled as the end of the line. 

2.8 Coloring

Jedit X supports automatic coloring of resource lists in HTML, C, CSS, Perl, JavaScript, 
etc. Coloring syntaxes may be modified freely. 

New Set
To create a new blank coloring syntax, click New Set, then input a name for the set and 
press OK. 

Delete



To delete a coloring syntax, select it from the menu and press Delete. 

Regular Expression for Target File
Use regular expressions to set the types of target files for which the coloring syntax is 
applied. For example, for HTML files, html$ is specified with regular expressions because 
HTML files end in "html." To include multiple regular expressions, separate each with a "|".

Syntax coloring as you type
Select this option to perform syntax coloring automatically. When so many coloring rules are 
applied that computer response lags, turn this option off.

Print syntax coloring
Select this option to print documents with syntax coloring. (When the black and white mode 
was specified at the Preferences Print>Colors, this setting will be neglected.)

Export Set
Click Export Set to export the selected coloring syntax. Use this function in conjunction 
with Import Set to exchange customized sets between users or computers. 

Import Set
Click Import Set to select a customized set to import. 

Create New Syntax Coloring Rules
Coloring syntax sets are comprised of multiple coloring rules. Using HTML as an example, 
there are five rules: Other tags, Anchor tags, Image Tags, Comment, and Comment 2. 

When defining rules, go in order from weak to strong rules, which is the same order that 
will be used when executing the rules. For example, Comment is a strong rule because even 
tags within it are commented. To add new rules, click the round + button. This adds a blank 
rule immediately after the selected rule. To delete a rule, select it and press the round - 
button. 

When creating new rules, first add the rule name in the Description column. Next, click the 
color well to set a color for the rule. Check the UL box when you wish to underline the 
syntax as well. Check the A=a box to make the rule case insensitive. Check the Data box to 
consider the text colored by the rule data, so that even if a string within the text corresponds 
to a strong rule, it will not be colored. 

If the text to be colored will all fit on one line, then add the regular expression for it on the 
Start Expression column. If there is a possibility that it will extend over multiple lines, then 
add the beginning to the Start Expression column and the end to the End Expression 
column. 



2.9 Wordwrap

Jedit X has three options for wordwrapping (a feature useful for Japanese text editing which 
determines which characters cannot come at line beginning or end): System Defaults, 
Japanese Custom Wordwrap, and Don't Wordwrap. These are selected in the Format 
subtab of New Document in Preferences. 

The Wordwrap tab of preferences allows detailed customization of processing when 
Japanese Custom Wordwrap is selected.

There are three built-in settings, which can be accessed from the Typical Examples 
submenu: Simple, Standard, and Strict.

Characters disallowed at line top
These characters are not allowed at the beginning of a line, and are sent to the end of the 
previous line. 

Characters disallowed at line end
These characters are not allowed at the beginning of a line, and are sent to the beginning of 
the next line. Select the Shift character at the top of next line to end of current line after 
these characters button to automatically shift the first character of the next line to the end of 
the current line instead of shifting these disallowed characters to the beginning of the next 
line.

Punctuation sticky for line ends
These punctuation marks are preserved at line ends instead of shifted to the first character of 
the next line. 

Characters which cannot be separated at line end
When these characters are repeated at the end of the line, they are all shifted to the beginning 
of the next line rather than being separated. 

Wordwrapping Limitations

Because Cocoa's text engine NSTextView does not originally support customized 
wordwrapping in this fashion, Japanese custom wordwrap has some limitations. 
If, for example, document width is set to 40 characters with Japanese custom wordwrap, 
then normally the 41st character would be sent to the line below. However, an exception is 
that if the 42nd character is a line break, then the 41st will not be sent to the line below no 
matter what. This is rarely problematic because the character before a line breaks is often a 
punctuation mark, which is not sent to the next line anyway. It does occur occasionally, 
however, so when necessary insert a "dummy space" before the 42nd character when you 
wish to send the 41st character to the next line. 



2.10 Print

Use the Print tab to set various options related to printing. Some of these settings may also 
be performed by selecting Jedit X from the dropdown menu in the center of the Print panel.

Colors
Select the color settings to print with. 

Line Numbers
Select whether or not to print line numbers. 

Print Invisible Characters
Select whether or not to print invisible characters (line break, tab, space, etc.)

Print Header
Select whether or not to print the header.

Print Footer
Select whether or not to print the footer. 

When document width is greater than paper width...
In page display mode document width will always match paper width, but in window 
display mode, you can set the printed image to scale down to the page width even when the 
document is wider than the page. 

Use the Auto Scale-Down menu to set how far the document may be shrunk. Use caution 
when setting this option to No Limit, as the characters may be shrunk too small to read. 

Set the Wrap Lines at Paper End function to automatically wrap lines when the auto-scale 
isn't sufficient to make the entire document fit on the page. 

2.11 HTML

Use the HTML tab to set various options related to editing HTML documents.

Web Browsers
Set the Web browser applications that are invoked when the menu View>Browse HTM 
with or Toolbar item Browse HTML is selected.

There are 2 ways to add a web browser to the list.
1) Drag & drop  a browser application icon onto the list.



2) Press the button "+" and choose  a browser application from the Open panel.

To remove a browser form the list, select the browser you want to remove and press the 
button "-".
You can change the browser name with double-clicking the name part.

To assigne a shortcut key, double-click the shortcut part (on the left side of the name part.)  
You may specify the shortcut key using a sheet below.

 
Open browsers in the background
When this option is set, the browser invoked will be shown in the background. Otherwise, it 
will be shown  in the foreground of the screen.

Use temporary files for browsing
When Browse HTML is selected, the HTML document is save to a file and the browser  
loads and displays it. If this option is not set,  the HTML will be directly saved to the 
document file. Otherwise, it will be saved to a temporary file.

Open HTML as Rich Text Document
By default, the HTML document  is opend as a plain text document and source codes are 
dispayed. When this option is set, HTML is interpretted and opened as a rich text document. 
(This function is available on Mac OS X 10.4 or later.)

When Saving Rich Text Document as HTML/Web Archive
when saving a rich text document as an HTML file or a web archive file, you can control its 
conversion using the parameters below. (This function is available on Mac OS X 10.4 or 
later.)
Document Type: DOCTYPE of the HTML file.
Encoding:  Text encoding of the HTML file.
Style Sheet: Use style sheet or not . And the type of the style sheet.
Preserve white space: If this switch is ON, the continous white spaces will be enclosed 
with the tag <span class="Apple-converted-space"> and </span>.





Chapter 3  File Menu

3.1 Plain Text and Rich Text 

Jedit X handles fundamentally two different types of files, Plain Text and Rich Text files. 

Plain Text files contain primarily text data alone. You may specify fonts and font color for 
these files, but only on the file level. That is, you cannot specify different fonts and different 
colors for different parts of the same file. Nor can you include images or links in Plain Text 
files. 

Rich Text Format (RTF), on the other hand, allows you to specify different fonts and 
different colors arbitrarily. That is, you could make every word a different color (if you 
wanted!). You can also include links in RTF.  If you wish to include images in your file, 
you can use RTFD (Rich Text Format Directory), which is the stronger and more versatile 
cousin of RTF. 

Plain Text File RTF File RTFD File

You may switch the format of an open file between Plain Text and Rich Text in 
Format>Make Rich/Plain Text. The file type will also determine the appearance of the 
ruler. 

Plain Text Ruler

Rich Text Ruler

The Plain Text ruler contains only hash marks, whereas the Rich Text ruler allows you to set 
font style, paragraph alignment, spacing, and soft tabs. 



3.2 Files Usable with Jedit X

Plain Text Files
Jedit X can both read and write Plain Text files. The .txt extension is often used with these 
files, but different file types such as HTML files (.html) or program source lists (.c, .h, etc.) 
are also often used for Plain Text files. 

Jedit X can automatically detect the encoding and line break type of Plain Text files when it 
first reads them. This capability includes Unicode (UTF-8 and UTF-16) as well as Roman 
character sets, multiple types of Japanese encodings, and encodings for Chinese, Korean, 
and many other languages as well. For details, see 2.4 Encoding.

Jedit X also supports automatic detection of three types of line breaks: Mac (CR), Windows 
(CR+LF), and Unix (LF). 

Plain Text files originally save text data only, which is saved in the data fork. However, Jedit 
X stores the following types of data in the resource fork for Plain Text files: 

Window size, window/page display mode, scale, read only or writable, hyphen 
processing, paper size, margins, header and footer information, colors, document width, 
document width mode (fixed, variable, or soft wraps), window position, selection area, 
scroll position, wrap indent information, wordwrap information, drawer status, tab 
width, bookmarks, font information, line spacing, ruled paper information, ruler status, 
toolbar status, line numbering status, invisible character display status, and auto-indent 
status.

You may determine whether or not to save these document attributes in the resource fork in 
the Save tab of Preferences. Keep in mind that the format for saving this information in the 
resource fork is unique to Jedit X, so it will be lost if you open up these files in other 
programs. 

RTF (Rich Text Format) Files
Jedit X can both read and write RTF files. RTF is a cross-platform standard document 
format supported by many programs proposed by Microsoft that allows embedding of 
detailed font and other information. 

RTF files usually have the .rtf extension, but even if they do not Jedit X can automatically 
detect them. 

All RTF programs keep the following document attributes in the data fork:



Window size, window/page display mode, zoom, read only or writable, hyphen 
processing, paper size, and margins.

Jedit X also keeps the following attributes in the resource fork:

Header and footer information, colors, document width, document width mode (fixed, 
variable, or soft wraps), window position, selection area, scroll position, soft wrap 
indent information, wordwrap information, drawer status, tab width, bookmarks, font 
information, line spacing, and ruled paper information.

You may determine whether or not to save these document attributes in the resource fork in 
the Save tab of Preferences. Keep in mind that the format for saving this information in the 
resource fork is unique to Jedit X, so it will be lost if you open up these files in other 
programs. 

RTFD (Rich Text Format Directory) Files 
Jedit X can both read and write RTFD files, which are RTF files with appended graphics.

RTFD is a format originated by Apple which contains the base RTF file plus a directory 
containing all image information. Even though RTFD files appear as a single file in the 
Finder, you can control-click them and select Show Package Contents to view the 
appended image files and the accompanying RTF file (TXT.rtf) directly. 

The extension for RTFD files is .rtfd. 

As with RTF files, document information for RTFD files is saved in the data fork and 
resource fork of TXT.rtf.

Text Clipping Files
Jedit X can both read and write Text Clipping files. Text Clipping files may be opened and 
saved as either Plain Text or Rich Text files, depending on their content. 

SimpleText Files
Jedit X can read SimpleText files created in Classic OS by SimpleText. However, Jedit X 
cannot write SimpleText files. 

SimpleText files are opened as Rich Text files. When you want to force opening as Plain 
Text files, use the option in the General tab in Preferences. 



SimpleText files are described by the file type 'TEXT', with 'styl' resources saved in the 
resource fork. 

Jedit4 Files
Jedit X can read Jedit4 files created with Jedit4.0/3.0. However, Jedit X cannot write Jedit4 
files. 

Jedit4 files are opened as Plain Text when they contain only one style and as Rich Text 
when they contain two or more styles. When you want to force opening as Plain Text files, 
use the option in the General tab in Preferences. 

The following objects are not converted when Jedit4 files are opened in Jedit X:
・Alias objects, sound objects, and QuickTime movie objects are ignored in Jedit X.
・Because Carbon and Cocoa use different font systems, fonts in Jedit4 documents are 

converted to the default font in Jedit X unless they are one of the following: Heisei 
Mincho, Heisei Maru Gothic, Hiragino Mincho Pro W6, Hiragino Mincho Pro W3, 
Hiragino Maru Gothic Pro W4, Hiragino Maru Gothic Standard W8, Hiragino Maru 
Gothic Pro W6, Hiragino Maru Gothic Pro W3, Osaka, Osaka Regular, MS Mincho, 
and MS Gothic. 

MS Word Files
Jedit X can both read and write MS Word files.

Cocoa itself supports the reading and writing of MS Word files, but the following 
incompatibilities do arise: 
・The objects not supported by Jedit X are ignored. 
・Images are also ignored upon opening. Images are also not saved to MS Word files. 
・Some fonts (especially Japanese fonts) are converted to the default font upon opening. 

MS Word XML(WordML) Files
Jedit X can both read and write MS Word XML files.
WordML file will be opened as a rich text document. Rich text that contains graphics can not 
be saved as a WordML file. (This function is not available on Mac OS X 10.3)



Web Archive Files
Jedit X can both read and write Safari Web Archive files.
Web Archive file will be opened as a rich text with graphics (RTFD) .  Rich text that 
contains graphics can  be saved as a Web Archive file.  (This function is not available on 
Mac OS X 10.3)

HTML Files
HTML file will be opened as a plain text file by default. But when the option "Open HTML 
as Rich Text Document" of the Preferences HTML is set to ON,  HTML files will be 
opened as rich text documents. Rich text that does not contain graphics can be saved as an 
HTML file.  (This function is not available on Mac OS X 10.3)

3.3 New Documents 

To create a new document, select File>New. A blank editing window will appear, with 
attributes (Plain/Rich Text, window size, font, background color, etc.) determined by the 
settings made in 2.3 New Document.

Open Template
Select File>Open Template to open a new file from a template. Templates are saved in 
advance, and may be HTML files, RTF files, Plain Text files, or any other kinds of file you 
wish to use as stationery for new documents. 

Create Template
To create a template file, first create the file that you wish to use as a template in Jedit X, then 
save it in the template folder at the following location: 

~/Library/Application Support/Jedit X/templates/ 

Select Finder>Open Template>Show in Finder to show the above template folder in the 
Finder directly. 

The next time Jedit X is launched, new templates will be shown in the File>Open Template 
submenu. 



3.4 Open Documents

There are four ways to open previously created documents. 

1. Double-click on the Jedit X icon
If the icons for files are as shown below, then they will open automatically in Jedit X when 
double-clicked. 
 

Plain Text File RTF File RTFD File

2. Drop file icon on the Jedit X application icon
This method allows you to easily open up files in Jedit X that otherwise would not 
automatically load in Jedit X.
 
If you drop a file onto the Jedit X application icon that Jedit X cannot open, the following 
dialog appears: 

 
3. Select File>Open...
Select File>Open to display an Open dialog that will allow you to open a file located 
anywhere on your computer or network. 

When opening Plain Text files, click the Sniff Encoding option to have Jedit X detect the 
encoding of the file. See 2.4 Encoding for details.

If this option is turned off, the encoding utilized when reading the file can by chosen 
manually from a dropdown menu. 

Turn the Ignore Rich Text Commands option on to instruct Jedit X to ignore the 
commands embedded in RTF files and open them as Plain Text. 

Turn the Load Jedit4 Document as Plain Text option on to read even Jedit4 documents 



with styles as Plain Text files. 

4. Select from the File>Open Recent submenu
The File>Open Recent submenu contains a list of recently opened files. If the file you wish 
to open is included in this list, select it to open it. 

Set the maximum number of files appearing in this list in the General tab of Preferences. 
The default setting is 10 files. 

Select Clear Menu from this submenu to remove all files from this list. 

If you want to remove a specific item from this submenu, selec that menu item with option 
key pressed.

3.5 Save Documents

Select File>Save to save the document window currently active. Select File>Save All to 
save all documents currently open. If the document is a new document, or if you select 
File>Save As..., a save dialog appears asking you to select a location to store the file. 

Saving Rich Text Files
Rich Text files can be saved as RTF or MS Word formats, but when images are added these 
formats are no longer applicable, and you must save in the RTFD format. When you try to 
save an RTF file to which images have been added, the following dialog appears: 

Click OK to show the RTFD save dialog, where you can save the file under a different name 
in the RTFD format. 

Saving Plain Text Files
Jedit X uses Unicode for internal processing, so English, Japanese, Korean, Arabic, JIS 4 
kanji, and other character sets can all be saved in the same document as long as Unicode 
(UTF-16 or UTF-8) is used. However, multiple character sets cannot be saved in the same 
document if Unicode is not used. 



For example, the following warning will appear if you open up a file in, for example, 
Western (ASCII) and then add characters such as (Japanese characters, accented roman 
letters, Korean, etc.) that are not included in this encoding. 

If you select Save with Western (ASCII) Encoding, all characters not included in that 
encoding will be replaced with '?'. If you select Choose Another Encoding, the save dialog 
will appear for you to specify another encoding.  If you select Check Incompatibility, the 
Encoding Compatibility window appear for you to find the incompatible characters.



3.6 Save Selection

When you wish to save only a portion of a document as another document, outline the 
portion you wish to save with the mouse and then select File>Save Selection... When the 
save dialog appears, specify a name and location for the new file. 

3.7 Revert Documents

To revert documents to the last time they were saved, select File>Revert. If a document has 
not been saved since it was opened, it will revert to the state at which it was opened. 

At default settings, the following dialog appears: 

If an error occurs during encoding detection and the characters appear garbled, this dialog 
can be used to correct the encoding and solve the problem. 

If you turn the Simple Revert without Dialog option on in the 2.2 General tab of 
Preferences, this dialog will not appear. 

3.8 Document Info

Select File>Document Info to display the Info tab of the document drawer on the left side 
of the document window (or the right side when there is no room on the left). 

The Info tab displays the following information: Document type, encoding, line endings, 
cursor location, and number of characters, visible characters, words, rows, paragraphs, and 
SJIS bytes. These figures are updated in real time as the document is edited. 

Encoding and line ending type are shown in a popup menu. If changes are made to these 
attributes, they take effect the next time the document is saved. However, encodings and line 



endings are not shown for Rich Text documents. 

Location
This shows the location of the cursor, or the first character of a portion of selected text. 
The location is also shown as a percentage of the entire document. 

Characters
This is the number of Unicode characters, including half-width characters, full-width 
characters, and control characters such as tabs and line breaks. 

Visible characters
This is the number of characters as described above without control characters. 

Words
This is the number of words in the document. Alphabetic words, a sequence of 
underscores, or strings of full-width characters are counted as words.  

Lines
This is the number of lines in the document. 

Paragraphs
The number of paragraphs is calculated by considering the text between two line breaks 
as one paragraph. 

SJIS bytes
This is the approximate size of the document calculated in real time. For purposes of the 
calculation, it is assumed that Shift-JIS encoding is used and that half-width characters 
(lower than code u0100) count as one byte and that full-width characters (code u0100 or 



above) count as two bytes. 
Path

Full path name of the document.

3.9 Properties

Select File>Properties to display the Properties tab of the document drawer on the left side 
of the document window (or the right side when there is no room on the left). Properties are 
available on Mac OS X 10.4 or later.

You can edit each value of Author, Company, Copyright, Title, Subject, Keywords and 
Comment. These values will be included in targets for Spotlight search.

Properties also can be shown in the page header or footer. For more, refer to 
 2.3.5 Header & Footer .
 

3.10 Page Setup

Select File>Page Setup... to display the Page Setup panel, which allows you to set paper 
size for printing. This automatically changes the page size used in page display mode. 
Settings made here are automatically reflected in page display mode. 

The options set in the Page Setup panel are shared with other applications. 

Jedit X does not support the Scale option in the Page Setup panel. A scale of 100% is 
always used, even if another number is input. 

3.11 Print

Select File>Print... to print the current document.

When printing a large file from window display mode, the program must first create an 
image for printing, so the following dialog may be shown briefly before printing. 
(In page display mode the screen image is the same as the printed image, so this will not 
occur.)



Select Jedit X from the third popup menu to make Jedit X-specific settings in the following 
dialog. 

The options shown here are the same ones shown in the Print tab of Preferences. Any 
changes made here will be reflected in the Print tab as well. For more details, see 2.10 Print.

3.12 Print Selection

Select File>Print Selection... to print only the selected portion of the current document. 
When the segment for printing is large, a print image must be created, so a dialog may 
appear briefly. When the Print panel appears, print normally. 

3.13 Using Jedit X as an external editor for other applications

As Jedit Rev.1.10 has supported the External Editor Protocol (ODB Editing protocol), you 



can edit and save documents with Jedit X in other application programs that support ODB 
Editing protocol.

Applications that you can use Jedit X as an external editor.

RBrowser
http://www.rbrowser.com/
You can use any editor applications as an external editor even if the editor does not support 
the external editor protocol. To assign Jedit X as an external editor, select a file that you want 
to edit in RBowser remote file list, press the Information button in the tool bar, set Jedit X as 
a "Defaults" tool in the "Tool" tab view of the Information panel. When you double click a 
file, Jedit X will be invoked and you can edit and save it with Jedit X.

Interarchy
http://www.interarchy.com/main/ 
It is very simple to assign Jedit X as an external editor. You just click the button "Set Jedit X 
as default ftp-editor" in Jedit X Preferences "General." Then you will see "Edit with Jedit X" 
in the menu "Listing" of Interarchy.
 
Cyberduck2.4
 http://cyberduck.ch/
 Choose "Jedit X" at the Preferences > Genera l > External Editor popup menu.

Fetch
http://fetchsoftworks.com/Features/macosx.html
http://www.hart.co.jp/fetch/index.php?code=dl4 (Japanese)
To assign Jedit X as an external editor, select "Misc" tab view of Fetch Preferences Panel, 
press "Obscure Options" menu button, select the "Specify external editor" menu item, and 
select Jedit X.

Captain FTP
http://captainftp.xdsnet.de/
To assign Jedit X as an external editor, choose "Actions" button of Captain FTP Preferences 
Panel, press "Edit files with" menu button, select the "choose..." menu item, and select Jedit 
X.

Pipe Version1.2 
 http://www.kcore.de/software/pipe/ 
Pipe helps you write, test, and debug shell scripts quickly. It is also ideal for learning 
scripting languages.  Choose "Jedit X" at the Preferences > Genera l > External Editor 
popup menu.

Fugu
http://rsug.itd.umich.edu/software/fugu/



Fugu will add Jedit X to the list of supported editors for the next release. In the meantime, 
you can add Jedit X now as following.
In the Finder, control-click on Fugu, and select Show Package Contents. Navigate to 
Contents > Resources. Open ODBEditors.plist with Jedit X. When the file opens, add this 
to the list:

<dict>
           <key>ODBEditorBundleID</key>
           <string>jp.co.artman21.JeditX</string>
            <key>ODBEditorCreatorCode</key>
            <string>JEDX</string>
            <key>ODBEditorLaunchStyle</key>
             <integer>0</integer>
             <key>ODBEditorName</key>
             <string>Jedit X</string>
</dict>

Quit and relaunch Fugu. Jedit X should be in the external editors list of Preferences > Files.

Following programs support the external editor protocol but you can not use Jedit X as an 
external editor because their selectable external editors are fixed and limited. Now we are 
asking the authors of those programs to add "Jedit X" item in their external editor selection 
menu. Their response will be more accelerated if you also e-mail them to support Jedit X.

Transmit
http://www.panic.com/transmit/
Open the "Preferences" panel. Click the  "Files" icon at the toolbar. Select the "(default)" 
editor at the "Custom File Editors" list. Press the button  . Select the application "Jedit X" 
by pressing the button "choose."

3.14 Open Location

Select File>Open Location... to open a remote URL. 



You can specify URLs with one of 4 methods as below.
・input directly using key board.
・drag an URL and drop onto the input field.
・copy by pressing the button "Copy URL from Safari."

・copy from the history menu  at the right side of the input field.

When the content of the URL is not text/html MIME type, an alert as shown below will 
appear.

URLs opened with the menu "Open Location" will be registered to the 'Remote' history of 
the menu "Open Recent."

Note: You cannot save the document back to its remote URL. If you wish to save it back, 
use one of  FTP applications that are described at  the former section "3.13 Using Jedit X as 
an external editor for other applications."



Chapter 4  Edit Menu

4.1 Window Display Mode and Page Display Mode 

There are two modes with which the document window is displayed: page display mode or 
window display mode. 

Window display mode is the basic mode most suited for editing documents. It does not 
contain printed elements such as margins, and only shows the textual (and images, if there 
are any) elements of the document. You can also divide the document window in window 
display mode. 

Page display mode is meant to give a preview of the document as it will appear printed. 
Hence it contains printed elements such as margins and headers/footers.

To switch between the two modes, select Format>Wrap to Window/Wrap to Page. 

Window display mode Page display mode

    



4.2 Window Elements

Proxy Icon
The miniature icon to the left of the document title in the Title Bar is called the Proxy Icon. 
Just as with the file's main icon in the Finder or Desktop, the Proxy Icon may be used to 
perform various operations. You can drag it to the desktop, for instance, to create an alias 
there, or you can drag it to an application icon in the dock to open up that document in that 
application. If you are editing an HTML document in Jedit X, just drag the Proxy Icon to the 
Safari icon in the Dock to open up that document in Safari. The Proxy Icon is greyed out if 
changes have been made to the file that have not been saved. The Proxy Icon cannot be used 
when greyed out. 

Directory Menu
Press Command while clicking on the document title to display the popup Directory Menu. 
This menu shows the directory hierarchy for the file, as shown below. Click on any of the 
locations shown in the menu to open up that location in a new Finder window. 



Toolbar
The oval button at the far right of the Title Bar is called the Toolbar Button. Click on it to 
show or hide the Toolbar. For details on how to customize the Toolbar, see 5.4 Toolbar.

Ruler
The triangular button at the top-right of the window is called the Ruler Button. Click on it to 
show or hide the Ruler. See 5.2 Ruler for more details about the ruler. 

Split Windows
In window display mode, it is possible to divide the document window up into different 
sections, each of which shows a different part of the same document. The top half of the 
viewer can show the beginning of a long document, for example, while the bottom half can 
show the end (or vice versa, although that would be confusing!). 

To split the window, click on the Split Button  at the top of the vertical scroll bar.

After the window is split, hover the mouse over the split bar dividing the two halves until it 
changes into . Next, hold the mouse button down while dragging up and down to move 
the split bar vertically within the document window. 

Double-click the split bar to remove it and restore the window to its original state. You can 
also click the Join Button  below the Split Button to do the same thing. 

You can split your document window into many sections, not just two. Just click on the 
Split Button multiple times to keep dividing the window. 

Line Numbers
To show or hide line numbers, select View>Show/Hide Line Numbers. To switch 
between line and paragraph numbers, select Line or Paragraph from View>Numbering 
Style. In window display mode, you can also show or hide line/paragraph numbers directly 



with the mouse. To hide them, just double-click on the numbers with the mouse. To show 
them, hover the mouse at the left edge of the window until it changes into , then click on 
the mouse. Finally, you can also change between line and paragraph numbers by clicking on 
the black triangular Line/Paragraph Numbering Button at the bottom-left of the window. 

Zoom Menu
The current zoom ratio is shown in the lower-left portion of the window. Click on this ratio 
to show a popup menu from which you can choose different zoom ratios. You may select 
from a range of 10-1200%. 

Read-Only/Writable Button
To the right of the Zoom Menu is a pencil-shaped icon that indicates whether or not changes 
can be made to the document. The  mark indicates that changes can be made and saved, 
while  indicates that the document cannot be changed (read-only). 

Click on the icon to change its status. When you are going to change to Read-Only, a 
confirmation alert as below will appear.

Status Window
To the right of the Read-Only/Writable button is an area where various messages (related to 
find or replacement results, etc.) are displayed. 

Layout Panel
To display the Layout panel (where you can edit margins and headers/footers), click the 
upper or lower margins when in page display mode.

4.3 Key Bindings 

Jedit X has many key commands for actions such as cursor movement, scrolling, or area 
selection. These key commands can be customized freely, as described in 2.6 Key Bindings, 



but the system defaults are as follows: 

Cursor Movement
Move Up ↑ ^P
Move Down ↓ ^N
Move Backward ⌥↑ ^B
Move Forward ⌥↓ ^F
Move Left ←
Move Right →
Move Word Left ⌥←
Move Word Right ⌥→
Move to Beginning of Line ^← ⌘←
Move to End of Line ^→ ⌘→
Move to Beginning of Paragraph ^A
Move to End of Paragraph ^E
Move Back One Page ⌥[pg up]
Move Forward One Page ⌥[pg dn] ^V
Move to Beginning of Document ⌘↑
Move to End of Document ⌘↓

Scrolling
Scroll Line Up None
Scroll Line Down None
Scroll Back One Page [pg up] ^↑
Scroll Forward One Page [pg dn] ^↓
Scroll to Beginning of Document [home]
Scroll to End of Document [end]

Area Selection
Move Up and Modify Selection ⇧↑
Move Down and Modify Selection ⇧↓
Move Left and Modify Selection ⇧←
Move Right and Modify Selection ⇧→
Move Word Left and Modify Selection ⇧⌥←
Move Word Right and Modify Selection ⇧⌥→
Move to Beginning of Line and Modify Selection ^⇧← ⌘⇧←
Move to End of Line and Modify Selection ^⇧→ ⌘⇧→
Move Paragraph Backward and Modify Selection ⇧⌥↑
Move Paragraph Forward and Modify Selection ⇧⌥↓
Page Up and Modify Selection ⇧[pg up]
Page Down and Modify Selection ⇧[pg dn]
Move to Doc. Beginning and Modify Selection ⇧[home] ⌘⇧↑



Move to Document End and Modify Selection ⇧[end] ⌘⇧↓

Insert
Insert Tab [tab]
Insert New Line [enter] [LF] [return]
Insert Page Break ⌘[return]
Insert Control Code None
Insert <br> (when editing HTML) ⇧[return]

 
Delete
Delete Backward [] ⌫ ^H
Delete Forward ⌦ ^D
Delete Word Backward ⌥⌫ ⌥[delete] ^⌥[delete]
Delete Word Forward ⌥⌦
Delete to End of Paragraph ^K
Delete Backward by Decomposing Prev. Char. ^[delete]

Other Editing Commands
Center Selection In Visible Area ^L
Transpose ^T
Yank ^Y
Cancel Operation ⌘.(Period) [esc]
Complete ⌥[esc] [F5]
Cycle to Next Input Keyboard Layout ⌘⌥[space]
Cycle to Next Input Script ⌘[space]
Increase Line Spacing None
Decrease Line Spacing None
Select Toolbar Find field None
Undo ⌘Z
Redo ⇧⌘Z
Cut ⌘X
Copy ⌘C
Paste ⌘V
Shift Left None
Shift Right None
ATOK Undo Fixing None
Toggle Regular Expression mode None

4.4 Mouse Controls

Single Selection



Drag the mouse where you wish to copy or cut. You can also expand/contract current 
selected area with Shift＋Click.

Rectangular Selection and Multi-Selection
On Mac OS X 10.4 (Tiger) or later:
You can select  rectangular area with option-dragging.
You can select  discrete multiple areas with cmd-dragging.

Click Operation
Single Click Move cursor to clicked location
Double Click Select clicked word
Triple Click Select clicked paragraph

Cmd＋Click Jump to selected URL or create 
new mail to email address

4.5 Text Attachments

Rich Text can contain various kinds of images and other objects, which are often called "text 
attachments." As with text itself, text attachments can be moved freely between Jedit X 
windows or to and from other Cocoa programs. This can be done either by means of either 
drag and drop or copy and paste. 

Image Text Attachments
When inserting image files (gif, tiff, jpg, png, pdf, etc.) into a text document, they are visible 
in the document window.

If images are larger than the width of the document, they will be resized automatically to fit. 
This will adversely affect their resolution. 

Animated GIFs
Animated GIFs may be embedded in Jedit X documents just like other image types. 
However, when deleting an area that contains an animated GIF, delete the GIF itself first 
before the rest of the area. If you delete the animated GIF along with the rest of the area, 
Jedit X may become unstable. 

QuickTime Movies
The following dialog appears when you attempt to embed a QuickTime movie into a Jedit X 
document.



Click Copy to store the QuickTime file itself in the RTFD directory, or Alias to create an 
alias for the original file in the RTFD directory.

Folders
The following dialog appears when you attempt to embed a folder.

Click Copy to store the folder and all its contents in the RTFD directory, or Alias to create 
an alias for the folder in the RTFD directory.

Other Text Attachments
When embedding other types of files into Jedit X documents, the file will be represented by 
an icon in the document window and the file itself stored in the RTFD directory.

Opening Text Attachments
Double-click on text attachment icons in the document window (or images for image files) to 
open the associated files just as though you had double-clicked on the file in the Finder. 
Double-clicking on a folder text attachment will open up the folder in the Finder window. 

The following dialog appears if you attempt to open a text attachment that has not been 
saved. Save it first before opening it. 



Rich Text files which contain text attachments are saved as RTFD (Rich Text File Directory) 
files. RTFD files are packages, which means that each RTFD file in fact contains the RTF 
file itself (TXT.rtf) and the text attachments. 

To view the contents (including all images and other text attachments) of an RTFD file, 
select the file in the finder and click it while holding down Control to open the context menu 
below. Select Show Package Contents.

The contents of the package will be shown in the Finder as below. You can extract text 
attachments from the Finder window below if you wish. 



Text Attachments and the Resource Fork
When you attached a file which has a resource fork, the resource fork will not be saved in 
the text.attachment. Therefore, when double-clicking that text attachment, it may not open in 
cases where the resource force is needed.

4.6 Undo and Redo

In Jedit X, you can "undo" or "redo" any action you take to alter your text. Enable this 
functionality by turning on the Enable Undo function in the 2.2 General tab of Preferences 
(this option is on by default).

Select Edit>Undo to take back any options you perform. You can use this function multiple 
times to undo more and more operations. 

If you undo too many operations, select Edit>Redo to restore the document one step at a 
time. 

You can also choose whether or not to clear all Undo information when the document is 
saved with the Don't clear undo when saving option in the 2.2 General tab of 
Preferences. Turning this option on means that you can undo past the point where you 
saved the document. 

4.7 Copy, Cut, Paste

When using Cut and Copy in Rich Text files, style information (font, style, font size, font 
color, etc.) ruler information (indents, hanging indents, line spacing, etc.), link information, 
and text attachment information (images, etc.) are also copied to the Clipboard and pasted 



into the destination document.

However, only the text information itself is copied from Plain Text documents. 

Copy as Plain Text
When copying from Rich Text documents, select Edit>Copy as Plain Text to copy text 
information only, ignoring all style and other information. 

Copy as Rich Text
When copying from Plain Text documents, select Edit>Copy as Rich Text to copy text 
and style information. 

Paste as Plain Text
When pasting Rich Text, select Edit>Paste as Plain Text to paste only the text information 
into the destination document, ignoring all style and other information. 

Paste Style Only
Select Paste Style Only to paste style and ruler information from the the beginning of the 
character string on the clipboard onto an area of selected text. 

Copy Style
Select Format>Font>Copy Style to copy style information only from the beginning of the 
selected character string. Ruler information is not copied. 

Paste Style 
Select Format>Font>Paste Style to paste the style information copied from the Copy Style 
function above onto the selected text. 

Copy Ruler
Select Format>Paragraph>Copy Ruler to copy the ruler information from the beginning 
of the selected character string. Text information is not copied. 

Paste Ruler
Select Format>Paragraph>Copy Ruler to paste the ruler information copied from the 
Copy Ruler function above onto the selected text. 

Text Properties Which Are Not Copied
Because bookmark links are a special Jedit X format, they cannot be copied and pasted. 

4.8 Drag&Drop

You may also use drag and drop functionality to move text or other objects between Jedit 



X windows, between Jedit X and other applications, or between Jedit X and the Finder. 

For example, to drag a section of text from one window to another, follow these simple 
instructions. 

First, select the text you wish to drag in the document window. Place your mouse inside 
this region, then click and hold down the mouse button. After  the pointer turns into an 
arrow symbol, drag the text to its destination in another window (it is necessary to hold 
down the mouse button for a second or so before the arrow appears). 

The same technique can be used to move text within the same document window. If the 
desired destination is beyond the range of the document visible in the screen, the window 
will scroll automatically up or down as necessary. Hold down Option to copy the text 
instead of moving it. 

Drop in the Finder
Instead of another document window or another application, you can also drop the text 
selection in the Finder (either the Desktop or a folder of your choice) to copy the text to 
that location in the Finder as a Text Clipping.

Style and ruler information from Rich Text files are saved in these Text Clippings, but 
images and other text attachments are not.

Drop Text Clippings in the Document Window
You may drag and drop Text Clippings (or Picture Clippings) directly from the finder into 
a Jedit X document window to insert them in your document. 

Drop Text Clippings in the Document Window
You may drag and drop Text Files directly from the finder into a Jedit X document 
window to insert the text into your document. Hold down Option while dragging to 
include the file as an attachment instead of inserting the text itself (the text file icon will 
appear at the dragged location). 

Drop Image Files
Drop image files (gif, tiff, jpeg, png, pdf, etc.) from the Finder into a Jedit X document 
window to insert that image in the document. Hold down Option while dragging to 
include the file as an attachment instead of inserting the image itself (the image file icon 
will appear at the dragged location). 

Drop Other Files
Other files types besides text or image files may also be dragged from the finder and 
dropped into a Jedit X document window. These files will be included as text attachments, 
and their icons appear at the dragged location. Double-click on this icon to open the image 
file in its default application. 



Drop Links
You can create links to any file or folder in your document window by holding down 
Control as you drag its icon from the Finder into Jedit X. A file path name and a link will 
be created automatically. (In Plain Text files the file path only is shown, as Plain Text files 
cannot contain links.)

Drop Files Into HTML Documents
Drop an image file (png, jpeg or gif) into an HTML document to embed the following type 
of image (<img>) tag:

<img src="xxxx.gif" width="999" height="999" alt="xxxx.gif" >

Or, for XHTML:

<img src="xxxx.gif" width="999" height="999" alt="xxxx.gif" />

The relative file path from the HTML file to the image will be used for the URL. If the 
HTML document has yet to be saved and so has not path, the absolute path will be used in 
the URL. 

Jedit X will automatically detect the image file type.

Drop a QuickTime Movie file into an HTML document to embed the following type of 
tags:

<object classid="clsid:02BF25D5-8C17-4B23-BC80-D3488ABDDC6B" width="---"
height="---"codebase="http://www.apple.com/qtactivex/qtplugin.cab">
<param name="src" value="file name">
<embed src="file name" width="---" height="---" autoplay="true" 
controller="true"
pluginspage="http://www.apple.com/quicktime/download/">
</embed>
</object>

Drop a flash Movie file into an HTML document to embed the following type of tags:

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" 
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/ 
swflash.cab#version=4,0,0,0" width="---" height="---">
<param name="movie" value="file name">
<embed src="file name" width="---" height="---" bgcolor="#" loop="false"
 quality="high"



pluginspage="http://www.macromedia.com/shockwave/download/index.cgi?
P1_Prod_Version=ShockwaveFlash" type="application/x-shockwave-flash>
</embed>
</object>

Alternatively, Drop any file other than above types to embed the anchor tag <a>.
When HTML document had a selected area and the file was droped in the selected area, the 
selected area will be surrounded by <a> and </a> tags as below.

<a href="xxxxx.html">[content of the selected area]</a>

The relative file path from the HTML file will be used for the URL. If the HTML 
document has yet to be saved and so has not path, the absolute path will be used in the 
URL. 

4.9 Find & Select

Using the menu "Find & Slect", you can select multiple ranges of text at once which match 
the pattern you specified. Then for that multiple selected ranges, you can do various 
functions such as copy, cut, changing character attributes, tools menu items and so on. 
(This function is available on Mac OS X 10.4 Tiger or later.)

This function has a much broader range of usage compared with Find & Replace function 
of the Find Panel. For example:
・Copy or cut every paragraph that has the pattern you specified.
・Copy or cut every paragraph that has not the pattern you specified.
・Set the character attributes (font, color or character size) to every text that matches the 
pattern you specified.
・Narrow down the selections by executing another "Find & Select" for the result of the 
"Find & Select."

Choosing the menu "Find & Slect", the panel below will appear in which you can specify 
the find conditions and the selection method.



The usage of Find Options, Scope, Find History menu and Find Patterns menu are as 
same as Find Panel.  Please refer to Chapter 6.

Specify the find pattern in the text field, choose the selection method from the popup menu 
and press the "Find & Select" button. You can choose the selection method among 
following 4 types.
・Select every matched area.
・Select every unmatched area. 
・Select every paragraph that has matched area.
・Select every paragraph that has not matched area.

4.10 Other Editing Commands

Balance Parentheses
In documents with many stacked parentheses (such as program source files), it is very 
easy to lose sight of which open paren is paired with which closed paren. At such times, 
select one parens and then select Edit>Balance to view the corresponding parens and the 
region enclosed by them. 

Double click one of the parentheses to highlight the region surrounded by those 
parentheses.  

Alternatively, place the cursor within two parentheses and then select Edit>Balance to 
highlight the region surrounded by those parentheses. 

The following 13 sets of parentheses are recognized:



Half-width   ( )   { }   [  ]  ｢ 」
Full-width （）〔〕［］｛｝〈〉《》「」『』【】

Note: ‘<  >’ are normally used as ‘greater than’ and ‘lesser than’ symbols, so these are not 
recognized as parentheses except in HTML documents. 

Shift Left/Right
Use Edit>Shift Left/Right to add or delete tab indents to shift left and right respectively. 
This function works only for tabs.

Date/Time Stamp
Select Edit>Date Stamp/Time Stamp to insert the current date or time at the cursor 
location. Format for date and time stamps may be selected from the 2.2 General tab of 
Preferences. 

Insert Line Break
To break lines, select Edit>Insert  Line Break. Note that the default line break you get by 
hitting the Return key is actually paragraph break; line break (0x2028) is used to break 
lines without starting a new paragraph.

Insert Page Break
To force a page break in page display mode or when printing, select Edit>Insert  Page 
Break (0x0c).

4.11 Spell Checking

Select the Spell Check Language
Spell checking is possible in multiple languages. English is the default language for spell 
checking but you may choose another language by selecting Edit>Spelling to open the 
Spelling panel, where you can set the language for spell checking. 

Spell Check Entire Document
To spell check the entire document, select Edit>Spelling>Spelling... For every misspelled 
word, a list of guesses will appear in the Guess field. Click on the correct spelling from the 
list and then press Correct (or double-click the correct spelling). If the correct spelling does 
not appear in the field by itself, enter it manually in the Spell field and then press Correct. 
Click Ignore if you do not want to change the word. Finally, click Find Next to proceed to 
the next misspelled word. 

Spell Check Part of the Document
Select the part of the document you wish to spell check (down to a single word), then select 
Edit>Spelling>Spelling...



Check Spelling as You Type
Select Edit>Check Spelling as You Type to have Jedit X automatically underline 
misspelled words in red as you type them. This option will be turned on automatically if you 
turn on the Enable continuous spell checking option on the 2.2 General tab of 
Preferences.

Add Words to the Dictionary
To add words to the dictionary, enter the word you wish to add in the Spell field and then 
click Learn. To delete a word from the dictionary, select it and press Delete. 



Chapter 5　View

5.1 Drawer

Select View>Show Drawer to open up the drawer on the left side of the document window 
(or on the right side if there is no room on the left). When open, select View>Hide Drawer 
to close the drawer. 

The drawer contains two tabs, the Info tab and the Bookmarks tab. See  3.8 Document Info 
for more information on the Info tab and 6.6 Bookmarks for more information on the 
Bookmarks tab.  

The drawer can also be opened with File>Document Info and Find>Bookmarks. 



5.2 Ruler

Select View>Show Ruler to display the ruler at the top of the document window. Select 
View>Hide Ruler to hide it. You can also show or hide the ruler with the small triangular 
button on the upper-right corner of the document window. 

 
In Plain Text documents, the ruler shows only document width hashes, while in Rich Text 
documents the style menu, justification menu, line spacing menu, and soft tab settings are 
also shown. 

Plain Text ruler

Rich Text ruler

Ruler Units
Select View>Ruler Units to select Points, Centimeters, Inches, or Characters as ruler 
units. When Characters is selected, the base character selected in the 2.2 General tab of 
Preferences is used to set width. 

Tab Settings
You can use the ruler to set paragraph indenting and tab settings. 

Right-pointing triangles  set left-justified tabs. 
Diamonds  set center-justified tabs. 
Left-pointing triangles  set right-justified tabs. 



Circles  set decimal tabs.

The down-pointing triangle on the left side of the ruler  sets the left paragraph indent. 
The down-pointing triangle on the right side of the ruler   sets the right paragraph indent. 
The rectangle  sets the hanging indent for the first line of every paragraph. 

To alter tab settings, drag one of the symbols described above from the tab pallete on the 
right side of the tool bar to the desired position on the ruler. You can also drag one of the 
existing tabs to any desired position on the ruler. 

To eliminate a tab, drag it outside the ruler. 

Style Menu
Use the Styles popup menu on the ruler to apply and save italic, bold, outline, and other font 
styles, as well as text and paragraph styles (font type, color, size, paragraph spacing, and line 
spacing). 

To apply some basic styles or favorite styles to any body of text, first select the text and then 
select the desired style from the Styles menu. 

You can also apply various styles to selected text by selecting the text and then selecting 
Other... from the Styles menu. Press the forward or reverse buttons to scroll through all the 
styles present in the document. When the desired style appears in the window, press Apply. 
Click Done to exit without applying any style. 

To make it easier to apply custom styles to any document, first select text with the desired 



style characteristics. Next, select Other... from the Styles menu, then press Add to 
Favorites. The selected style will then appear in the Styles menu for quick access. To 
include font type in this style, click Include the font as part of the style. To include 
spacing, tabs, and other style elements, click Include the ruler as part of the style.

Paragraph Alignment Buttons
You may align selected paragraphs or the document as a whole with the paragraph alignment 
buttons. Choose from among Align Left, Center, Justify, and Align Right. These settings 
can also be performed by selecting Format>Paragraphs. 

Spacing Menu
To change line and paragraph spacing, use the Spacing menu on the ruler. Select the text 
you wish to change,  then select Single, Double, or Other. 

Select Other to make custom settings for line height (distance from the top of one line to the 
top of the next), inter-line spacing (distance from the bottom of one line to the top of the 
next), and paragraph spacing (distance from the bottom of one paragraph to the top of the 
next). 

5.3 Line Numbers 

Select View>Show Line Number to show line numbers in the gutter at the left of the 
window. Select View>Hide Line Number to hide the line numbers when visible. Use 
View>Numbering Style to alternate between line and paragraph numbering. 

In window display mode, you can also hide line or paragraph numbering by double-clicking 
on the gutter where they are displayed. To display them again, place the mouse on the left 
edge of the window until the cursor symbol changes to , then click the mouse. Finally, 
you can use the black triangular button at the bottom of the gutter to alternate between line 
and paragraph numbering. 

In page display mode, click the mouse in the left margin to alternate between line numbers, 
paragraph numbers, and no numbering.

Line or paragraph numbering may take some time to appear when opening large  documents. 



This is because calculation of the document layout continues in the background when the file 
is opened, and line/paragraph numbering cannot be shown until the document layout is 
complete. This accounts for the time lag when files of 1 MB or larger are opened. 

5.4 Control Characters

 Select View>Show Control Characters to show  control characters as ^ marked 
alphabets. (This function is available on Mac OS X 10.4 or later.)

HEX  Disp HEX Disp HEX  Disp HEX Disp
00 ^@ 08 ^H 10 ^P 18 ^X
01 ^A 09 (TAB) 11 ^Q 19 ^Y
02 ^B 0A (LF) 12 ^R 1A ^Z
03 ^C 0B (VT) 13 ^S 1B ^[
04 ^D 0C (FF) 14 ^T 1C ^\
05 ^E 0D (CR) 15 ^U 1D ^]
06 ^F 0E ^N 16 ^V 1E ^^
07 ^G 0F ^O 17 ^W 1F ^_

5.5 Invisible Characters

 Select View>Show Invisibles to show  invisble characters as below. 
 

Name Hex code Display
Single Space 0x0020
Non Breaking Space 0x00A0

Double Bytes Space 0x3000

Tab 0x0009

Line Break 0x2028

Paragraph Break 0x000a

Carridge Return 0x000d

Page Break 0x000c



Select View>Show Invisibles>Show Them to show all invisibles that you specified at the 
Preferences>New Document>View>Show Invisibles.



5.6 Toolbar

Jedit X has a customizable toolbar similar to those found in Finder, Mail, Address Book, 
and other native OS X applications. 

To show or hide the toolbard, select View>Show/Hide Toolbar or click the oblong Toolbar 
button at the upper-left of the document window. 

Customize the Toolbar
Select View>Customize Toolbar... to pull down the toolbar customization sheet. This sheet 
contains all the items that can be included on the toolbar. 

Drag the items you wish to place on the toolbar from the sheet onto the toolbar. You can 
also drag the default set. To remove an item from the toolbar, drag it outside the toolbar. You 
can also re-arrange items on the toolbar by dragging them to different positions. 

Select toolbar display from among Text Only, Icon Only, and Icon&Text. Select Use 
Small Size to make toolbar items smaller. 

Toolbar Item Descriptions

Click to open the Find panel. When already open, the Find panel will move to the front. This 
button is the same as selecting Find>Find...

Enter words in the Find field to perform searches without opening up the Find panel. Search 
results are displayed in a separate Find Results window. Press Escape to move the focus 
back to the original cursor location in the main document window. 

Click the magnifying glass to show the Find popup menu, which allows you  to set various 



search options. Here you can also select previously searched words to search again or clear 
the search history. 

 

Enter words in the Replace field to perform replacements without opening up the Find panel. 
Enter the word to replace in the Find field and the replacement word in the Replace field, 
then press the circular arrow icon in the Replace field to display a popup window with 
replacement options. Select one to perform the replacement. Here you can also select 
previously replaced words or clear the replacement history.

 

Click to display the Font panel. This button is the same as selecting Format>Font>Show 
Fonts. 

The Font menu allows you to change fonts directly from the toolbar. The first item in the 
Font menu shows the current collection of fonts, all of which are shown direclty below. 
Select a different font collection using the submenu to change the fonts shown below. These 
font collections correspond to those used in the Font panel. Select Other Fonts... from the 
Font menu to open up the Font panel. (When the collection "All Fonts" was selected, Jedit X 
start-up time will be slowed in the case of a low speed machine or a system that tons of fonts 
were installed.)

You can use the Font panel to customize collections by adding or removing fonts, as well as 
make collections of your own. Make custom collections to make the Font menu as useful as 
possible. 

The Size menu allows you to change font size directly from the Toolbar. First select the text 
whose size you wish to change, then click on the ▼ button in the Size menu to select from a 
popup menu of sizes. You can also input a number directly into the Size menu. 



The Color menu allows you to change text color directly from the toolbar. First select the 
text whose color you wish to change, then click on the Color menu and select a color. 
Sixteen colors are shown on the Color menu, but if you need a different color than these 
defaults, select Other Color... The Color panel will appear, from which you can set any 
color possible. 

The Marker Pen allows you to change the character background color for the selected area as 
if a maker pen marks the text. When  you select the item "Clear", the character background 
color will be cleared.

Click to show the Color panel to change font color. 

 

The Encodings menu shows the current encoding. When you select a different encoding 
from the menu, that encoding will take effect the next time the document is saved. 

The Line Endings menu shows the current line endings. When you select a different line 
ending from the menu, that line ending will take effect the next time the document is saved. 

 

The Doc Info button opens the Info drawer tab. 



The Show Bookmarks button opens and closes the Bookmarks drawer tab. 

The Bookmark it button makes a new bookmark of selected text. 

 Caret Location  shows the current location of the caret in terms of character , line, , 

paragraph , or page . Select which of these units to display caret location in from the 
popup menu on the right side of the menu. You can use the up and down arrows in the 
center of the menu to change caret position manually, or you can input a number directly into 
the field on the right side to move the caret.  

Ruler Position shows the current position of the caret on the ruler. 

The Kerning buttons allow you to change the kerning of selected text directly from the 
toolbar. "Kerning" refers to altering the spaces between characters. First select text, then 
press the left button to squish characters closer together, the right button to separate them, or 
the middle button to restore default kerning. These buttons are equivalent to options found in 
Format>Font>Kern. 

Left button: Format>Font>Kern>Tighten
Center button:　 Format>Font>Kern>Use Default
Right button: Format>Font>Kern>Loosen



The Baseline buttons allow you to change the baseline of selected text directly from the 
toolbar. First select text, then press the left button to raise the baseline, the right button to 
lower it, or the center button to restore the default baseline. These buttons are equivalent to 
options found in Format>Font>Baseline. 

Left button: Format>Font>Baseline>Raise
Center button: Format>Font>Baseline>Use Default
Right button: Format>Font>Baseline>Lower

Use the left and right buttons while depressing Option to quickly apply superscript and 
subscript:

Left button: Format>Font>Baseline>Superscript
Right button: Format>Font>Baseline>Subscript

 First select text, then press the left button to apply superscript, the right button to subscript,  
If you press the Subscript button for superscript text, normal baseline will be applied.

The View button allows you to switch between window display and page display views 
from the toolbar. These buttons are the same as selecting Format>Wrap to Page/Wrap to 
Window.

The Doc Width button changes the document width mode and width in window display 
mode. These options are the same as those found in Format>Document Width... This 
button has no effect in page display mode because document width is fixed to paper size. 

The Save button saves the document. It is the same as File>Save. 



The Browse HTML button browses the HTML document with a browser of 
the icon. If you press the small triangle, you can choose a browser  from the 
browser menu. The browsers in the menu are defined at the browser list of 
the Preferences  2.11 HTML.
When the document is not HTML, the Browse HTML icon is displayed with 
gray color and deactivated.

The Print button prints the document. It is the same as File>Print.

The Customize button displays the Toolbar customization panel. It has the same effect as 
View>Customize Toolbar...

5.7 Document Coloring

Select View>Document Coloring... to display the document coloring sheet, which allows 
you to change colors of various parts of the document. 



Coloring information is saved in the resource fork of each file. 

5.8 Syntax Coloring

The syntax coloring function allows automatic coloring of comments, functions, tags, and 
other aspects of HTML or programming languages, making them easier to read. 

Jedit X supports syntax coloring of HML, C, CSS, Perl, JavaScript, and other languages. 
Syntax coloring can be customized in the 2.8 Coloring tab of Preferences. 

Coloring sets which have been defined in the Coloring tab of Preferences appear in the 
submenu of View>Syntax Coloring. Select the language of your choice apply those rules 
to the current document. 

Select Re-Color in the View>Syntax Coloring submenu to apply the selected syntax to the 
entire document. Use this function when Color as You Type was not originally activated, 
or when syntax coloring has become out of sync with the document content. 

Select Color as You Type in the submenu to perform automatic in-line coloring. Turn this 
option off when numerous coloring rules slow coloring down or slow key response. 

5.9 Browse HTML

Select View>Browse HTML with>[a browser]  to browse  current HTML document on a 
web browser. If you choose All Browsers, it will be browsed on all  web browsers.

The browsers are defined on the Preferences  2.11 HTML .

This menu item will be disabled when the editing document is not HTML.

5.10 View HTML Source

Select View>View HTML Source  to convert  current rich text  to HTML source code 
which will be displayed on a new document. (This function is available on Mac OS X 10.4 
or later.)

Att the  Preferences  2.11 HTML, you can specify how to covert rich text to HTML 

This menu item will be disabled when the editing document is a plain text or a rich text with 



graphics.



Chapter 6  Find

6.1 Search Strings 

To search for certain characters or words in your document (“search string”), first select 
Find>Find... 

Enter the search string in the Find field, then press Find Next. The search will begin at the 
cursor location and then proceed until it finds a match, which will be highlighted. 

Press Find Next again to show the next instance of the search string in the document 
(default keyboard shortcut is Cmd+G). A short beep will sound if there is no next 
instance. If the Wrap Around option is turned on, the program will return to the top of 
the document and resume search from there. 

You can also select Find>Find Next from the menu instead of pressing the Find Next 
button. 

If you turn on the Entire Document option under Find All/Replace All, then press Find 
All, then each instance of the search string will be shown in context in a Find Results list. 
Alternatively, select Selection to only search within a specific portion of the document. On 
Mac OS X 10.4 or later, search for rectangular selection or multiple selections is also 
supported. When nothing was selected, the entire document will be searched  even if the 
Selection option was ON. 
You can abort search/replacing all by pressing cmd+period key.



Double-click any line in the Find Results list to jump to  that location in the original 
document. 

When pressing the button Save in the Find Results list, the results will be saved to a plain 
text or rich text file. For each result, the first line displays the full path name and  matched 
character range and the second line displays the content of the found paragraph.
If you double-click the path name part, the file of the path name is opened and the matched 
character range is selected and shown. This function is called "Tag Jump."

Press the   button to the upper-right of the Find field to display a popup list of recent 
search items. Select any of these previous search strings to input it automatically in the 
Find field (the original find options for that search will be restored as well). 
When selecting the menu with option key pressed, the selected menu item will be removed 
from the popup list.

Press the  button to the lower-right of the Find field to display a list of frequently used 
regular expression parameters. Select Add Pattern to add the regular expression currently 
in the Find field to this list (together with current find options). 



When the Regular Expressions option is off, hold Option down when pressing Return or 
Tab to include those characters in the search string. 

Select Find>Use Selection for Find after selecting a portion of text to open the Find panel 
with the selected text already entered in the Find field. 

Select Find>Go to Toolbar Find Field to shift the cursor from the document window to 
the Find field in the Toolbar. 

Select Search Backward in the Find panel to search backwards in the document from the 
point of the cursor instead of forwards. 

Select Wrap Around in the Find panel to return to the top of the document to continue 
searching. If this option is not selected, then the top half of the document will not be 
searched if you began the search from the middle of the document. 

Select Ignore Case in the Find panel to make your search case insensitive. 

Select Full Word from the popup menu to return hits on your search string only if it is an 
entire word. For example, if this option is not selected, then a search for “boy” will also 
return instances of “boycott.” Select Starts With from the popup menu to return hits only 
if the search string begins words. Finally, select Contains to always return hits on the 
search string for words which contain the string within any part of them. Jedit X considers 
the half-width roman character "_" and all double byte characters one word. Therefore, the 
concept of "word" does not fit Japanese documents well, so please select Contains for 
these files. 

When the Regular Expression option is selected, you can use regular expression 
parameters to expand search capabilities dramatically.  When the option selected, the 
background color of the find/replace field will turn to light blue so that you can tell the 
search mode easily.

Press the  button to show the regular expression Help window. 

Click More Options to open up the 2.7 Find tab in Preferences. 





6.2 Replace

To replace one word with another, either place the original word in the Find field of the Find 
panel and the replacement word in the Replace field, then press Replace; or select 
Find>Replace. (If the original word is not found in the document, then no replacement will 
be made.)

Press the Replace&Find button in the Find panel or select Find>Replace&Find to make 
one replacement at a time. Alternatively, press the Replace All button in the Find panel or 
select Find>Replace All to perform a global replacement on the entire document (or on the 
selected text if some text is selected).  On Mac OS X 10.4 or later, replacement for 
rectangular selection or multiple selections is also supported.

Press the   button to the upper-right of the Replace field to display a popup list of recent 
replacement items. Select any of these previous items to input it automatically in the 
Replace field together with the corresponding item in the Find field. The original find 
options for that replacement are restored as well. 
When selecting the menu with option key pressed, the selected menu item will be removed 
from the popup list.

Press the  button to the lower-right of the Find field to display a list of frequently used 
regular expression parameters. 

Select Add Pattern to add the items currently in the Find and Replace fields to this list 
(together with current find options). 



6.3 Multi-File Find/Replace

Jedit X can perform searches in multiple files and folders on your computer at the same time. 
Select Multi-File Search on the lower-left of the Find panel to designate the target files or 
folders. 

Use this button to switch between single file or multi-file search. Press it to show the Multi-
File Search drawer, or press it again to hide the drawer and return to normal Find mode. 

To search currently opened documents, set the checkbox "Search currently opened 



documents" to ON.

To search files on your local volumes, set the checkbox "Search currently opened 
documents" to OFF.

On the left of the drawer is a target file list, while on the right are lists for specifying 
included or excluded file types. 

 To add a target file, press the  button on the lower-left corner of the panel to display a 
file selection dialog: 

The file selection dialog will reflect the included and excluded file types above. You may not 
select excluded file types. You may select multiple files at once, or entire folders full of files. 

You can also drag files and folders directly from the Finder into the file list. 

Folders will appear as folders in the file list. Their entire contents, including subfolders, will 
be searched. To show folder contents in the file list, click on a folder to select it, then double-
click on the folder while holding down Command. 

To delete files from the file list (so they will not be searched), select the file(s) to be deleted 

and press the  button at the bottom-left of the list. To delete all files from the list, press 

Clear All. 

Double-click on a file in the list to open it, or double-click on a folder to open it in the 



Finder. 

Execute Multi-File Find
Once your target files have been determined, click Find All in the Find panel. Progress is 
shown in the following window:

Once searching is complete, press Done to show the following Search Results window. 
Double-click any search result to jump to that location within the file, or double-click the file 
name to open that file.



Two Methods for Multi-File Replace
Multi-file replacements may be performed by opening the window for each file or by writing 
the replacements to the file directly without opening the document. Select which option to 
use with the Replace without opening windows option in the bottom-right of the Multi-
File Search drawer. 

It is safer to make replacements on files while opening them up for two reasons. First, you 
can Undo the replacement. Second, if you do not save the file, then changes made to it will 
not be permanent. However, if you are making replacements on many files at once, opening 
up windows for each of them may cause the screen to fill up with windows and computer 
performance to slow, making the operation take longer.

Performing replacements on files directly without opening up their windows is much faster. 
However, you cannot perform an Undo in this case should you make an error. As a safety 
measure, turn on the Leave backup files when replacing option before performing the 
replacement. With this option, if you make a change to a file called "abcd.html", then the pre-
replacement file will be saved as "abcd~.html" should you need to revert back to the original 
file. 

Execute Multi-File Replace
Once your target files have been determined, click Replace All in the Find panel. Progress is 
shown in the following window:



Once the replacement is complete, press Done to close the Progress window. 

When opening up files to make replacements in them, you must save changes before closing 
to make the changes permanent. 

When files are not opened for replacements, Jedit4 documents, MS Word documents, Text 
Clippings, and SimpleText documents will be saved in RTF/RTFD or TXT formats (for 
Rich Text or Plain Text files respectively) under a different name. This is because Jedit X 
does not support writing of those file formats (it does support writing of MS Word, but not 
fully). 

File Sets
Add frequently used files or folders to file sets so that you do not have to repeat the same 
process every time you wish to perform a multi-file find or replace operation on them. With 
the files you wish to add in the file list window, select Add Current File List to the 
Menu... from the File Sets popup menu. 

Enter the name of the set and then click OK to add the set to the File Set menu. To delete a 
set, open the File Set menu and then hold down Option while selecting. 

Target Files and Excluded Files



There may be times when you want to search for only a specific kind (or kinds) of files for 
search and replace. Or, you might want to exclude a certain kind of file from your search. 
Use the Target Files and Excluded Files lists to accomplish this. 

For example, to look for HTML files alone, press the  button below Target Files, then 
type the four letter extension "html". Henceforth all files but those with the "html" extension 
will be grayed out and ineligible for search and replace. Do not include the "." in the 
extension. 

You may also specify file type in addition to the extension. Specify the 'TEXT' file type to 
only search for Plain Text files, for instance. All file types be four letters surrounded by 
single quotes as in the previous sentence. 

The Excluded Files list is a list of files that are not suitable for Find and Replace. This list is 
already populated with a list of extensions and file types for applications, images, movies, 

and other kinds of binary files. Use the  and  buttons to add or remove items from 
this list. 



6.4 Multiple Replace

The multiple replace function allows you to define a set of replacements that are performed 
simultaneously. You can use multiple replace on a single file or in a multi-file replace 
operation. 

To use multiple replace, select Find>Find... to open the Find panel, then click on the 
Multiple Replace tab. The following table will be displayed: 

Input your desired Find and Replace terms in their respective columns, then click Replace to 
perform the replacement. All other options operate as with a normal replacement. 

Replacements are carried out in order from line 1. Drag and drop list items to change their 
order in the table. 

Press  to add a line after the selected line. 

Press  to delete the selected line(s). 

Press Clear to delete all list items. 

Press Save to save the current multiple replacement set. Sets are saved as tab-delimited 
UTF-8 text files with one entry per line in the following format: 

Find Term＋Tab＋Replace Term＋Line Break



Press Load to use a previously saved multiple replacement set. Then a popup menu that 
shows recent saved/loaded files will appear. If you can't find the file in the menu, select 
Other. To remove a menu item from the recent menu, select it with pressing the option key.

6.5 Regular Expressions

About Regular Expressions
Regular expressions are a method for performing text searches or replacements based on a 
powerful and flexible set of parameters. You may specify wildcards, a range of characters, 
invisible characters, and other options in your search and replaces. For example, you could 
use regular expressions to change an entire page of various dates in the US format 
(“1/20/2004”) to the equivalent Japanese format (“2004/1/20”). 

Regular expressions were originally created to help programmers, but recently they have 
become more widely used, and are supported by an array of scripting languages, text 
editors, databases, and command tools. 

There are different variations of regular expressions depending on when and for what 
program (or platform) the engine (the part of the program which actually performs the 
expression engine function) was developed. Jedit X uses the Oniguruma engine, a 
powerful version of regular expressions which was developed recently and was used in 
the object oriented scripting language Ruby 1.9.

Introducing Regular Expressions
Regular expressions consist of two types of characters: “meta-characters” used to express 
a variety of functions and meanings, and “literals,” which express regular text strings. You 
can get started with regular expressions right away by learning just a few basic meta-
characters and the syntax for using them. 

For one basic illustration of regular expressions, we will use use an example of 
manipulating dates. 

The regular expression to represent the date format mm-dd-yy can be written 

\d+-\d+-\d+

\d is a meta-character for half-width numerals from 0-9. + is a meta-character for one or 
more repetitions of the previous character. Therefore, \d+ can stand for a string of numerals 
of any length. Searching for \d+-\d+-\d+, then, with the Regular Expressions option 
checked, would return hits on any piece of text in the form of xx-yy-zz, where x, y, and z are 
numerals. 



If we want to search for dates using slashes as well as hyphens, we can use 

\d+[-/]\d+[-/]\d+

as our regular expression. [] represent a "class", so [-/] refers to either a hyphen or a slash. 
To add the possibility of periods, as in "mm.dd.yy", we would use

\d+[-/.]\d+[-/.]\d+

This regular expression is useful enough as it is to identify dates, but we can make it even 
more precise. 

First, because months are limited to 1-12, we can write 1?\d for the months, which signifies 
a "1" zero or one times, followed by a string of numbers (\d). 

Next, because days are limited to 1-31, we can write [1-3]?\d for the days, which signifies a 
number from 1-3 zero or one times, followed by a string of numbers (\d). 

The year will be either two or four numerals, which can be expressed as (\d{4}|\d{2}). \d{4} 
refers to a series of four numerals, while \d{2} refers to a series of two numerals. | means 
OR, so this expression denotes a series of either two or four numerals, enclosed in 
parentheses as a group. 

When combined, these expressions come out as

1?\d[-/.][1-3]?\d[-/.](\d{4}|\d{2})

To prevent a number from coming directly before our date, we write

(?<!\d)1?\d[-/.][1-3]?\d[-/.](\d{4}|\d{2})

(?<!\d) is a "negative lookbehind" that prevents matching with any character string 
following a numeral. 

The previous expression would also match on the months "13" and "15", so we can make 
the expression yet more precise by writing

(?<!\d)(1[0-2]|\d)[-/.][1-3]?\d[-/.](\d{4}|\d{2})

In Greater Depth…
There are many references, both printed and on the web, that explore regular expressions 
in great depth. Here is the book that helped popularize them. 



Mastering Regular Expressions
By Jeffrey E. F. Friedl
2nd Edition July 2002 
ISBN: 0-596-00289-0
http://www.oreilly.com/catalog/regex2/ 

Below are simple explanations of the meta-characters used in Oniguruma.
 
1. Basic Elements 

  \       Escape character
Use ‘\’ when you want to use a character that would normally be considered a 
meta-character as a literal, or normal character. For example, \^, \$, \*, \+, \?, \\ 
would be used to designate ^, $, *, +, ?, \ as literals instead of meta-characters. 
 

  |       Alternation (match either)
For example, ‘abc|xyz’ returns matches on either  ‘abc’ or ‘xyz’. 

  (...)   Group

Forming groups allows you to refer to the group later when replacing text which 
matches the group using \1, \2, etc.
For example,  the following regular expression denotes a date comprising of three 
groups:

        ([0-9]+)/([0-9]+)/([0-9]+)
 Year / Month / Day

If we wish to switch the order of the groups (to alternate between US and Japanese 
date formats, for instance), we can use the following as a replacement string to 
reorder the date:

             \2.\3.\1
Month / Day / Year

                      
  [...]   Text class

Use ‘[ ]’ to define a class of characters. This can include ‘-‘, which designates a 
range, or ‘^’, which is a negator. Single-width or double-width ranges may be 
specified. "&&" is the intersection operator, which is the second weakest operator 
after "^". 
    
Example:   [abc]         
       Matches for ‘a’, ‘b’, or ‘c’.



        
Example:   [A-Z]         
       Matches for capital letters ranging from ‘A’ to ‘Z’. 

Example:   [a-z]         
       Matches for lowercase letters ranging from ‘a’ to ‘z’. 
        
Example:   [^a-z]        
        Matches for characters other than ‘a’ to ‘z’ (lowercase half-width alphabet)
 
Example:   [a-xABC]     
       Matches lowercase letters in the range of ‘a’ to ‘x’ and either ‘A’, ‘B’, or ‘C’.
       
Example: Intersection operator     
       [a-w&&[^c-g]z] ==> ([a-w] and ([^c-g] or z)) ==> [abh-w]        
        

2. Characters

  \t           Horizontal tab (0x09)
  \v          Vertical tab         (0x0B)
  \n           Line break             (0x0A)
  \r           Return             (0x0D)
  \b          Backspace (0x08)　 Note: effective only for text classes
  \f           Page break            (0x0C)
  \a           Bell               (0x07)
  \e           Escape key code (0x1B)

  
  \nnn        Octal

  When expressing "0" in octal notation, use \000.
  
  \xHH       (Two digit) Hexadecimal

  When expressing 0-255 in hexadecimal notation, use \x??.
    

  \x{7HHHHHHH} Large Hexadecimal
 For example, double-width space (u3000) is \x{3000}.
 

   \cx           Control characters
  For example, to express the control character ^A (0x01): \cA
  

3. Character Types



  .        Wildcard (matches all characters except line breaks)
  Example: ‘a.d’ matches on any of the following:  

and add dandy a漢d

  \w      “Word” (alphanumeric) characters, plus ‘_’ and multibyte characters
           
  \W       Non-word characters (symbols and other non-alphanumeric characters)
  \s       Whitespace characters (\t, \n, \v, \f, \r, \x20)
  \S       Non-whitespace characters
  \d       Numbers
  \D      Non-number characters

4. Quantifiers

    ?       Makes the preceding pattern optional (greedy).
    Example: an?d    
    Matches ‘and’ or ‘ad’ but not ‘annd’.
    

    ??      Matches preceding pattern 0 or 1 times (reluctant).
    Example: Difference between "an?" and "an??"
     an?   matches 'an' in 'and' (greedy)
     an?? matches 'a' in 'and' (reluctant)
    

    *         Matches the previous pattern zero or more times (greedy).
    Example: an*d    
    Matches ‘and’, 'ad' in ‘advance’, and 'ad' in ‘add’. 
    (Any character strings beginning with ‘a’, contains ‘n’ 0 or more times, and  
ending with a ‘d’.) 
    

    * ?      Matches the previous pattern zero or more times (reluctant).
Example: '.*bbb' matches 'aaa bbb bbb bbb' in 'aaa bbb bbb bbb ccc' (greedy), but 
'.*?bbb' matches 'aaa bbb' in the same text string (reluctant). 

    +       Matches the preceding pattern at least once (greedy).
Example:    an+d
Matches 'and' and 'annd', but not 'ad' in advance or 'add'.     

    +?     Matches the preceding pattern at least once (reluctant).

    {n,m}   Matches pattern n-m times (inclusive) (greedy).
    
    {n,m}?  Matches pattern n-m times (inclusive) (reluctant).



    
    {n,}     Matches pattern n or more times (greedy). 
    
    {n,} ?   Matches pattern n or more times (reluctant). 
    
    {,n}    Matches pattern up to n times (inclusive) (greedy).
    
    {,n}?    Matches pattern up to n times (inclusive) (reluctant).
        
    {n}     Matches pattern exactly n times (greedy).  
    
    {n}?    Matches pattern exactly n times (reluctant). 

Possessives (greedy and does not backtrack after repeated)
?+ 1 or 0 times
*+ 0 or more times
++ 1 or more times

5. Anchors

  ^       Matches line beginnings.
 Example: ^subj
 Matches lines that begin with ‘subj:’. 

  $       Matches line endings. 
  Does not include line breaks. When you want to include line breaks, use ‘\n’. 
  Example:    ^$    matches blank lines (not including line breaks)
  Example:    ^\n   matches blank lines (including line breaks)

  \b      Matches word boundaries. 
  
  \B      Matches non-word boundaries. 
  
  \A      Matches the top of a string of text. 
  
  \Z      Matches the end of the text, or character closest to end if final character is a line 
break. 
  
  \z      Matches the end of the text.
  
  \G      Matches the previous end of match position. 

6. POSIX Brackets



POSIX brackets are a system for making regular expressions easier to read. They refer to 
character classes only. For example, [[:lower:]] is equivalent to [a-z], while [[:^lower:]] is 
equivalent to [^a-z]. 

    alnum   Alphanumeric characters
    alpha    Alphabetical characters
    ascii      0 - 127
    blank    \t, \x20
    cntrl      Control characters
    digit      Numerals 0-9
    graph    All visible characters excluding white space
    lower     Lower case alphabetical characters
    print      All visible characters including white space
    punct    All visible characters excluding alphanumerical characters
    space    \t, \n, \v, \f, \r, \x20
    upper    Upper case alphabetical characters
    xdigit    Hexadecimal （0-9, a-f, A-F）

7. Extended Groups

  (?#...)         Comment
Use this function to add comments to regular expressions. "..." in the example above 
are comments. 

  (?imx-imx)    Local option preferences. Use to override Ignore Case or other Regular 
Expression options set in Find tab of Preferences. 
  

                      i: Ignore case
                      m: "." matches line break
                      x: extended form
For example, specify (?i) to make case insensitive in the rest of the regular express, 
and (?-i) to make case sensitive. 

   
  (?imx-imx:subexpression)    Subexpression option

Local option preferences for subexpressions. 

  (Subexpression)              Captured group
Remembers the group "(...)" for backreference with \1, \2 etc. 

 (?:Subexpression)            Not captured group
The subexpression is grouped but matched strings are not remembered. 



  (?= Subexpression)           Look ahead
Match ends when the subexpression matches the next pattern.
For example, when searching for foo(?=bar), foo in foobar is matched but food is 
not. 

  (?!Subexpression)            Negative look ahead 
Match ends when the subexpression does not match the next pattern.
For example, when searching for foo(?!=bar), foo in food is matched but foobar is 
not. 

  (?<=Subexpression)           Look behind
Match is effective only after the subexpression matches a string. 
For example, when searching for (?<=foo)bar, bar in foobar is matched but food 
is not. 

  (?<!Subexpression)           Negative look behind
Match is effective only after the subexpression fails to match a string. 
For example, when searching for (?<!foo)bar, bar in xxxbar is matched but 
foobar is not. 

  (?>Subexpression)            Atomic group 
Example: (ab)*ab matches on abababab but not on (?>(ab)*)ab.

  (?<name>Subexpression)   Define named group 
Remembers the group "(...)" for backreference with \1, \2 etc., and also names the 
group as \g<name> for later referencing. The group must be named without 
punctuation, and the first letter must be a capital alphabetical character.

6.6 Bookmarks 

You can place bookmarks in documents that let you return to any position within the 
document at a single click. 

Adding Bookmarks
Select the section of text you wish to bookmark, then select Find>Bookmark Selection 
The new bookmark will be placed in the Bookmarks drawer tab.  The drawer will open 
automatically if it isn’t open already. 

If the Bookmarks drawer tab is open, you may select a piece of text and drag it (hold 
down the mouse button for a second before dragging) to any place in the bookmark list 
you desire to create a bookmark automatically. 

Finally, you can also create a bookmark by selecting a piece of text and clicking on the 



 button in the lower-left corner of the drawer. 

Jump to Bookmark
Clicking on any bookmark in the bookmark list allows you to jump instantly to that 
portion of the document. 

Select Bookmark
Clicking on the bookmark with option key pressed. This does not cause the jumping.

Change Bookmark Names
Bookmarks are initially named with the same text that you select to create the bookmark. 
To change bookmark names, double-click on a bookmark within the list to edit the name, 
as shown below: 

Reorder Bookmarks
You can reorder bookmarks within the list by selecting a bookmark (or multiple 
bookmarks) and dragging them up or down to the desired place within the list. 

Delete Bookmarks
You can delete bookmarks by selecting the bookmark (or multiple bookmarks) within the 

list and either pressing the  button in the bottom-left corner of the drawer or pressing 
Delete. 

Create a Bookmark Hierarchy
You can create a bookmark hierarchy, with an outline or stratified structure that places 
some bookmarks within others. To change a position of a bookmark (or multiple 

bookmarks) within the hierarchy, select it and press the  button or the  button in the 
bottom of the bookmark drawer, depending on whether or not you want to shift the 
bookmark further in or out within the hierarchy. Click the triangular symbol next to 
bookmarks that have other bookmarks within them to show or hide the sub-bookmarks. 

You can also drag and drop bookmarks to move them within the hierarchy. 

Embedding Bookmarks



You can embed bookmarks in the document window by selecting them (singly or multiple 
bookmarks) and dragging them from the bookmark window to the desired place in your 
document. A link will be created automatically to the bookmarked location. 

You can also drag bookmarks to other documents, including new documents. However, 
because links are not saved in Plain Text documents, they must be Rich Text. 

When dragging a bookmark from one document to another, the document which is the origin 
of the bookmark must first be saved. If it has not been saved the following dialog will 
appear: 

Because the file information for links are saved as aliases (which means the destination file 
may be moved or renamed without affecting the link), the linked file should be saved before 
the link is made to assure a stable link. 

Bookmark Menu

The bookmark popup menu appears when you click on the  button in the lower-right 
corner of the bookmark tab.

Select Expand All to expand all levels of the bookmark hierarchy. 

Select Collapse All to collapse all levels of the bookmark hierarchy. 



Select Sort by Location to sort selected bookmarks (at all levels of hierarchy) by their 
position within the document. 

Select Sort by Name to sort selected bookmarks (at all levels of hierarchy)  alphabetically. 

Select Import from Find Results to import all instances of found words in the Find results 
window into the bookmark list. 

Select Reset Structure to eliminate all bookmark hierarchies, making all bookmarks "flat". 

Select Clear All to delete all bookmarks. 

6.7 Jump

Jump to Selection
Select Find>Jump to Selection to jump to the currently selected text (when you have 
scrolled beyond sight of the selection, for instance). 

Previous Selection
Select Find>Previous Selection to jump to the previous selection. A previous selection is 
defined as a piece of previously selected text that is more than 200 characters and 100 
vertical points away from the current selection. Select the function again to return to the 
original location. This function allows you to jump back and forth easily between two 
spacially separated locations in the document. 

Go to Line
Select Find>Jump to Line... to jump to any position in the document. Positions can be 
specified in terms of character, row, or paragraph. 



Chapter 7  Format

7.1 Fonts

Select Format>Font to change font options for the selected section of text (or for the entire 
document for Plain Text files, as these files cannot maintain multiple style settings). 

Font and font size may also be changed from the 5.4 Toolbar.

Show Font Panel 
Select Format>Font>Show Fonts to show the Font panel, which is shared with other 
system applications. On the Font panel you can change fonts, style, size, color, and other 
font settings. 

For example, follow these steps to change font and font size with the Font panel:

1. Select the text for which you wish to change fonts. 
2. Select Format>Font>Show Fonts to show the Font panel.
3. From the Family window select the font style, then from the Typeface window 
select the specific typeface you wish to use. If the font you wish to use is not shown 
in the Family window, select All Fonts in the Collections window or type the name 
of the desired font in the Search field at the bottom of the panel. 

A preview of any font selected is shown in the Preview panel at the top of the Font 
panel. If the Preview panel is not visible, select Show Preview from the Action 

menu  at the bottom-left corner of the Font panel (or click and dragon the 
small circular symbol at the center-top of the Font panel). 

4. Use the Size slider or select a size from the Size window to adjust font size. 

5. If there are so many fonts that you have a hard time locating the ones you use on a 
regular basis, you can use the Collections window to organize your fonts. You may 
also leave the Font panel open in the background if you change fonts often. 
 

The Font panel is a system-wide OS X application, so for greater detail in its use, please see 
System help:

 1. Click Mac OS Help, or select Help>Mac Help from the Finder. 
 2. Click Browse Mac OS X Help in the main window. 
 3. Click Applications and documents in the list on the left. 
 4. Click Changing fonts, styles, and colors for text from the submenu on the 
right.



 5. Select which topic you wish to read.  
 
Font Style
Select Bold, Italic, Underline, or Outline from Format>Font to apply those attributes to 
selected text. 

These menu options will be greyed out if the font in use does not support them (for example, 
Hiragino Kaku Gothic Pro does not support italics).

Style Panel
Select Format>Font>Style... to display the following Style panel. 

To apply a style already in use somewhere in the document to the selected text, use the arrow 
buttons to scan the document for different styles, which will appear in the window. When 
the desired style appears, click Apply. 

To add a style to the Favorites list for easy selection, first select a piece of text which uses 
that style, then open the Style panel and press Add to Favorites. A new sheet will appear 
for you to name the style. On this sheet, select Include the font as part of the style to 
include font information in the style. Select Include ruler information as part of the style 
to include ruler information such as tabs and spacing.
 
 Font Size
 To change font size of selected text, select Format>Font>Bigger/Smaller. When the area 
selected contains different size fonts, their relative sizes will be maintained as the font sizes 
are increased or decreased. 
  
Kern
Select Format>Font>Kern to adjust the spacing between letters in the selected area of text. 



This may also be performed from the Toolbar. 
 
Ligature
Select Format>Font>Ligature to select options for ligature, which determines how some 
letter combinations fit together. 

For example, turning ligature on causes the two f's in "off" to combine into a single glyph (ff 
as opposed to ff).
 
Baseline
Select Format>Font>Baseline to raise, lower, superscript, or subscript the baseline of 
selected text. This function raises or lowers text in relation to text around it. This may also be 
performed from the Toolbar. 
 
Character Fore Color
Select Format>Font>Character Fore Color to display the Colors panel, which allows you 
to change the character color of selected text.  You may also leave the Colors panel open in 
the background if you change colors often. 

Character Back Color
Select Format>Font>Character Back Color to display the Colors panel, which allows 
you to change the character background color of selected text.  

7.2 Paragraphs

Selecting various options within the Format>Paragraph menu affects the paragraphs 
highlighted. (However, selections affect the entire document in Plain Text files.)

You may also change paragraph alignment and line spacing from the Toolbar. 

Paragraph Alignment
Select Format>Paragraph>Align Left>Center>Justify>Align Right to apply those 
options to the paragraph(s) highlighted. 

Line Spacing
Select Format>Paragraph>Line Spacing... to open the Line Spacing panel, from which 
you can set line spacing for the paragraph(s) highlighted. 

Note: You cannot decrease line spacing past the font height. If a line spacing smaller than 
the font height is set, the minimum line spacing value possible will be used. 

Tab Width
Select Format>Paragraph>Tab Width... to open the Tab Width panel, from which you 



can set tab widths for the paragraph(s) highlighted.

7.3 Links

Links may be embedded in Jedit X Rich Text files. Linked text is colored blue and 
underlined. When you hover your mouse over it the link destination appears and the mouse 
pointer turns into a hand. Click on the link to open it. 

Link to URLs
You can drag and drop links from Safari or other browsers directly into Jedit X documents. 
When you drag a link, the link information is carried with it, so that clicking the link within 
Jedit X will open up that URL in the browser window. 

You may also copy links to URLs directly from the browser by dragging the URL icon 
(directly to the left of the URL) from your browser to the Jedit X window. Alternatively, 
you can select the link text itself and drop it in the Jedit X window while holding down 
Control to embed a link to that location. 

Link to Files/Folders
Drop a file or a folder from the Finder into Jedit X while holding down Control to insert the 
file path to that file or folder as a link. Click on the link to open the file or folder in the 
default application. 

For Plain Text files, the file path is displayed but no link is created. 

Link to Bookmarks
You can drag bookmarks from the Bookmarks drawer tab to anywhere in your document 
to create a link to the bookmarked location. You can even drag bookmarks among different 
Jedit X documents. 

Display/Change Link Information
Select a link and then select Format>Link... to show the following type of link sheet. Here 
you can view and change link destination information. 



Change this link information directly or by dropping files, URLs, or bookmarks into the 
window. 

Select Clear Link to delete the link information. 

7.4 List

List paragraph attribute has been supported since Mac OS X 10.4.

You can use bullets or numbers to distinguish items in a list.

Select  Format> List, then choose a bullet or number from the Lists pop-up menu.

To customize a bullet or number, select Bullet/Number popup menu.
 
You can add more lines to your list by placing the cursor at the end of a list item and 
pressing Return. To finish the list, press Return twice after the last list item.

7.5 Table

Table paragraph attribute has been supported since Mac OS X 10.4.

Adding a new table



Place the cursor where you want to add the table. Choose Format>Table.

In the Table window, type the number of rows and columns you want (or use the arrow 
buttons to add or subtract rows and columns).

To adjust the height or width of a row or column, place the pointer over the border of a cell. 
When the pointer changes to a double arrow, drag the border to change the dimensions of 
the row or column.

Customizing table cells
Once you have created a table, you can adjust the alignment of text in the table or customize 
the border and background colors for selected cells.

Select the table cells you want to work with. Choose Format>Table.

To set alignment, select the horizontal and vertical alignment settings you want to use.

To customize a border, set the border size (in pixels) by typing a number or using the arrow 
buttons. To set a border color, click the color cell to open the Colors window and change the 
color.

To customize the table background, choose Color Fill from the Cell Background pop-up 
menu, then click the color cell to open the Colors window and change the color.



Merging and splitting table cells
In a table, you can combine several cells into one large cell, or you can split a single cell into 
several new cells.

To combine cells, select the cells you want to merge. Choose Format>Table, and click 
Merge Cells.

To split a single cell, select the cell and choose Format>Table. Click Split Cells.

Creating a table within a table
 You can create a table inside an existing table cell. This "nested" table lets you split a single 
cell into additional rows and columns.

Select a cell in an existing table. Choose Format>Table, and click Nest Table.

Set the number of rows and columns you want to use. After you set up the nested table, you 
can select cells in that table and format the text alignment, borders, and background for them.

7.6 Page Layout

Select Format>Page Layout... to show the Page Layout sheet, where you can change 
margin and footer settings. 

You can also access the Page Layout sheet from page display mode by double-clicking in 
the margins. 

Refer to 2.3.5 Header & Footer for information on setting headers and footers. 

7.7 Document Width

When in window display mode, select Format>Document Width... to show the Document 
Width sheet below. (In page display mode the document width is always determined by 
paper size set in File>Page Setup...)



When set to Follows Window Width, the document width changes fluidly along with the 
size of the document window, which is changed with the sizing box in the lower-right 
corner of the window. 

When set to Fixed Width, document width stays constant at the set width, which can be 
defined in points, centimeters, inches, or characters. When defined in characters, the 
character set as Base Character in the General tab of Preferences is used to determine 
width. 

When set to Follows Page Width, document width will match paper size selected in 
File>Page Setup... This allows the on-screen document to closely match the printed final 
product even in window display mode.

When set to Don't Wrap Lines, document width is treated as infinitely wide, so no soft 
wrapping occurs. This setting is used for program source files. 

These settings may also be applied from the Toolbar. 

7.8 Switch Between Plain/Rich Text

Select Format>Make Plain/Rich Text to switch the current document between Plain and 
Rich Text file formats. 

Switching from Rich Text to plain text will cause you to lose all font, font color, link, and 
other style information as well as images and text attachments. If you wish to change, click 
OK at the following dialog:



See 3.1 Plain Text and Rich Text for more information on the differences between Rich Text 
and Plain Text file formats. 

7.9 Switch Between Window/Page Display Mode

Select Format>Wrap to Page/Window to switch between page display mode and window 
display mode. 

These settings may also be applied from the Toolbar. 

See  4.1 Window Display Mode and Page Display Mode for more information on the 
differences between window display mode and page display mode. 

7.10 Ruled Paper

Select Format>Ruled Paper... to display the Ruled Paper sheet. 

For Rich Text files, check the Use Ruled Paper for Wrap to Page Mode button and then 
set the other parameters to show the following warning dialog: 

See 2.3.4 Paper Layout for more information on setting ruled paper parameters. 

7.11 Prevent Editing

Select Format>Prevent/Allow Editing to make the document read-only or writable. 



The pencil symbol at the bottom of the document window shows whether the document is 
read-only or writable. Clicking on the pencil icon also allows you to toggle between 
allowing or disallowing editing. 

7.12 Auto-Indent

Select Format>Auto-Indent to turn auto-indent functionality on or off. 

When on, new paragraphs will inherit indents (blank spaces at the beginning of the 
paragraph, either tabs, half-width spaces, or full-width spaces) from the paragraph above. 

7.13 Allow Hyphenation

Select Format>Allow Hyphenation/Disallow Hyphenation to turn automatic line-end 
hyphenation on and off. 

When on, hyphens will automatically be added to long words at the end of lines to split them 
up. When off, long words at the end of lines will be sent down to the line below. 

(This function is effective only when editing English documents, not Japanese.)

7.14 Wordwrap

Wordwrapping is a function often found in Japanese text editors which disallows some 
characters at the beginning or endings of lines. Select Format>Wordwrapping to choose 
from three wordwrapping options: System Defaults, Japanese Custom Wordwrap, or 
Don't Wordwrap. 

Select System Defaults to use the default system settings. Punctuation at the end of a line 
will be sent down to the following line along with the previous character.

Select Japanese Custom Wordwrap to use custom wordwrap settings. See  2.9 
Wordwrap for details. 

Select Don't Wordwrap to wrap lines strictly according to document width, no matter what 
characters fall at line beginning or end. 

7.15 Wrapped Line Indent 



When in Plain Text documents, select Format>Wrapped Line Indent... to display this 
sheet: 

Wrapped line indent allows Jedit X to automatically indent lines that are soft-wrapped (when 
a new line is created because the document width is exceeded, but not when a hard line break 
is added, such as by pressing Return). This function makes lists easy to read for HTML, 
other programming documents, or any document with long lists. 

You may set the indent width. Set "0" to indent the same as the top line, input a positive 
number to make the indent deeper, or input a negative number to make the indent shallower. 



Chapter 8  Tools

8.1 Hard Wrap Lines with LF

"Hard wrapping" refers to inserting a line break at a set width in the document. Select 
Tools>Settings for Hard Wrapping... to show the following dialog. 

The width at which to apply the hard wrapping may be defined in points, centimeters, 
inches, or characters. When defined in characters, the character set as Base Character in the 
General tab of Preferences is used to determine width. 

You can also set whether or not to remove existing line breaks (the code for which is LF) 
and prefixes, and whether or not to add prefixes after wrapping. 

When Auto Indent is turned on, the indent from the first paragraph is inherited in later 
paragraphs. 

To hard wrap a segment of text, first select it and then use the tool described above. If no 
portion of text is selected, then the paragraph where the cursor is will be affected. 

Hard wrapping may also be performed by the Services menu in applications other than Jedit 
X.

8.2 Remove LF's and Prefixes

Select Tools>Remove LF's and Prefixes to remove line breaks, indents, and prefixes from 
the selected area. If no portion of text is selected, then the paragraph where the cursor is will 
be affected.



Use this tool if you wish to rewrap a portion of text at a different width. For example, if you 
have a paragraph that was hard wrapped at 80 characters but you wish to change to 72 
characters, use this to remove the hard wrapping before re-wrapping to 72 characters. 

Remove LF's and Prefixes does not remove line breaks which constitute blank lines. 
(Also, a space is automatically inserted in between English words to make sure they do not 
join when the line break is removed.)

8.3 Prefixes

A "prefix" is a character that is inserted at the beginning of each paragraph in email or other 
applications. 

Prefix...
Select Tools>Prefix... to make prefix-related settings. 

You can also set whether or not to insert prefixes after indents. Finally, click Set to Default 
to make the current setting the default setting for other documents. 

Add Prefixes
Select Tools>Add Prefixes to add prefixes to the currently selected paragraph. If no portion 
of text is selected, then the paragraph where the cursor is will be affected.

You may add multiple prefixes by repeating the step above. Spaces which are part of the 
prefix will not be inserted between multiple prefixes. 

Remove Prefixes
Select Tools>Remove Prefixes to remove one level of prefix from the selected paragraph. 

Use Selection as Prefix
Select Tools>Use Selection as Prefix to use the selected text as a prefix. 

8.4 Sort



To sort text, first select the text you wish to sort and then select Tools>Sort... The following 
dialog appears.

You can choose to sort on the nth character or the nth word of every line. When using the 
latter, you must also specify delimiters, or the boundaries between words (tabs, spaces, etc.). 
For example, the regular expression for tabs is \t. 

Select In Descending Order to sort from largest to smallest. 

Select Sort as Numerical Value
Check this option to sort numbers after the sort position according to their numerical value. 
For example, clicking this option would cause 1214 to follow 123, whereas leaving it 
unselected would cause 1214 to come first because 1 comes before 3. 

Select Ignore Case to treat small or large caps the same in the sorting process. Leaving this 
option unselected will cause all full-capped words to be grouped together. 

Select Ignore Half/Full Width to treat small or large caps in the sorting process.  Leaving 
this option unselected will cause all half-width and all full-width characters to be grouped 
together. 

Select In Japanese Pronunciation Order to sort Japanese words based on their "a-i-u-e-o" 
readings rather than their Unicode codes, which would result in a meaningless order. This 
requires longer than a normal sort because of the conversion of kanji to phonetic readings. 

8.5 Advanced Sort



Reverse Lines
Select Tools>Reverse Lines to reverse the order of the paragraphs in the selected order. The 
relationship of lines within each paragraph (without a line break) are not affected. Use to 
reorder a set of lines from ascending to descending, or vice versa. 

Remove Duplicate Lines
Select Tools>Remove Duplicate Lines to remove lines that are identical to other lines 
adjacent to it within the selected area. 

Count Duplicate Lines
Select Tools>Count Duplicate Lines remove and consolidate identical adjacent lines as in 
the function above. This function, however, counts the number of duplicate lines erased and 
inserts the number at the beginning of the paragraph. 

8.6 Convert Tabs and Spaces

When using the tools described below, first select an area of text with the mouse and then 
the tool itself. If no area of text is selected, the entire document will be affected. 

Tabs to Spaces
Select Tools>Tabs to Spaces to convert tabs in the selected area to half-width spaces. 

Spaces
Select Tools>Spaces to Tabs to convert repeated spaces (half- or full-width) to half-width 
spaces. 

Remove Leading Spaces
Select Tools>Remove Leading Spaces to remove all spaces (half- or full-width) and tabs at 
the beginning of a line. 

Remove Trailing Spaces
Select Tools>Remove Trailing Spaces to remove all spaces (half- or full-width) and tabs at 
the end of a line. 

Full-Width Space to Single Spaces
Select Tools>Full-Width Space to Single Spaces to convert all full-width spaces to two 
single-width spaces. 

8.7 Fix Garbled Characters

When characters from other encodings (such as the German umlaut or the Spanish accent) 



are included in a Japanese (Mac OS) document, these additional characters may become 
garbled when Jedit X converts the file to Unicode. 

For example, if, "München" is read as Japanese (Mac OS), it will be converted to "M殤
chen", a garbled word. 

When this happens, select the garbled word(s) and select Tools>Fix Garbled Characters. 
The following window will appear: 

To fix the garbled characters, you need to specify two encodins. One is the wrong encoding 
that caused the problem. Another is right encoding of the  garbled text.

In above case, select Japanese (Mac OS) at the first encoding popup menu and Mac OS 
Roman at the second encoding popup menu.

Click Fix to fix the word within the document window. 

Note: If the entire document is garbled, then an incorrect encoding was used to read the 
document. Select File>Revert..., then select the correct encoding and re-load the document. 
See  3.7 Revert Documents 

8.8 Convert Character Type

To Full-Width/To Half-Width
You can convert katakana (a Japanese syllabary), letters, numerals, letters, and symbols 
from half-width to full-width and vice versa. Select Tools>To Full-Width/Half-Width. 
When the following dialog appears, select the type of characters you wish to convert. 



Select Save as Defaults to save the settings as the default. The default will be used when 
Tools>Unify Full/Half-Width Characters is selected. 

(The cnvFlag field appearing in this dialog is the parameter for the AppleScript conversion 
operations toHankaku and toZenkaku. Copy this parameter to paste into your AppleScript 
program.)

Unify Full/Half-Width Characters
Select Tools>Unify Full/Half-width Characters to perform "To Full-Width" and "To-
Half-Width" at the same time. Parameters used will be those previously selected on the 
conversion sheet above. This function is very useful for making all punctuation etc. 
consistent. 

Change Case>To Upper/To Lower/Capitalize
Select Tools>Change Case>To Upper/To Lower/Capitalize to convert all of the selected 
text to either upper case, lower case, or capitalized. "Capitalized" refers to the first character 
of a word being upper case while the rest is lower. If no text is selected when these 
commands are carried out, they will affect the word closest to the cursor. 

Kanji to Hiragana



Select Kanji to Hiragana to convert kanji in the selected area to hiragana. Katakana is not 
affected. 

Hiragana↔Katakana
Select Hiragana↔Katakana to convert hiragana to katakana, or vice versa.

8.9 Show Character Code

When you wish to see the computer code for any given character, select the character and 
then select Tools>Show Character Code with Tool Tip. Then, when you place your 
mouse near any character in the selected area, a yellow Tool Tip field will appear with the 
corresponding code for that character. Shift your mouse to view the codes for different 
characters. 

Unicode and Shift-JIS codes are displayed. 

Tool Tips are automatically cleared with scrolling, typing, or other actions. 

8.10 Check Encoding Compatibility

When you wish to check the encoding compatibility for the selected area, select  
Tools>Check Encoding Compatibility.

Change foreground color of incompatible characters
When incompatible characters were found, those characters are colored with the color of the 



color well. By clicking the color well, you can change the color with a color panel.

Mark incompatible characters to Find Result List
When incompatible characters were found, those characters are registered to the Find Result 
List. You can easily detect those characters from the Find List.

Replace incompatible characters to Find Ret
When incompatible characters were found, those characters are replaced to the character '?'.



Chapter 9  Window

9.1 Minimize

Select Window>Minimize to minimize the front (active) window and send it to the dock. 

9.2 Bring All to Front

Select Window>Bring All to Front to bring all Jedit X windows to the front. 

9.3 Last Document to Front

Select Window>Last Document to Front to bring the Jedit X window furthest to the rear 
to the front. 

9.4 Tiling

Select Window>Tile 2 Documents to resize and align the frontmost two document 
windows above and below each other on the screen. 

Select Window>Tile 2 Documents Vertically to resize the two frontmost document 
windows vertically and align them beside each other on the screen.  

Select Window>Tile All Documents to resize and align all Jedit X document windows 
above and below each other on the screen. 

Select Window>Tile All Documents Vertically to resize all Jedit X document windows 
vertically and align them beside each other on the screen.



Chapter 10  Services  

Using the Services menu, you can call Jedit X text editing functions from other programs as 
well. 

10.1 Open Selected File

Select Services>Jedit X>Open Selected File from anther program to open a file in Jedit X 
from a selected full path name or file object. 

10.2 Open Selected Text in New Document

Select Services>Jedit X>Open Selected Text in New Document to open a piece of 
selected text in Jedit X as a new document. 

10.3 Hard Wrap Selected Text to Justify

Select Services>Jedit X>Hard Wrap Selected Text to Justify from another program to 
justify text selected in that document with hard line breaks. A Jedit X window will open 
briefly when performing the operation, but this window disappears once the operation is 
complete. 

This function is very handy in email editors or when posting to bulletin boards on the net. 
You can also access this function through a shortcut, which is described below in  10.5 



Assign a Shortcut Key to the Services Menu.

10.4 Unify Full/Half-Width Characters

Select Services>Jedit X>Unify Full/Half-Width Characters to unify the half- and full-
width characters in the selected text. A Jedit X window will open temporarily to perform the 
operation, then close automatically. 

10.5 Remove LFs and Prefixes from Selection

Select Services>Jedit X>Remove LFs and Prefixes from Selection to remove LFs and 
prefixes in the selected text. A Jedit X window will open temporarily to perform the 
operation, then close automatically. 

10.6 Add Prefixes with Hard-wrapping for Selection

Select Services>Jedit X>Add Prefixes with Hard-wrapping for Selection to add 
prefixes for  the selected text. A Jedit X window will open temporarily to perform the 
operation, then close automatically. 

10.7 Assign a Shortcut Key to the Services Menu

Normally you would not assign shortcut keys to the Services menu in order to avoid overlap 
with other applications. However, the method below shows how to use unused key 
combinations to make the Services menu even more useful. 

For example, here we show how to assign the shortcut Command+Option+K to Hard 
Wrap Selected Text to Justify.

First, select System Preferences... from the Apple menu, then select Keyboard & Mouse, 
then select the Keyboard Shortcuts tab. 



Open All Applications under Application Keyboard Shortcuts. Next, click the  
button to show the following sheet: 

Select All Aplications from the popup menu, then enter Hard Wrap Selected Text to Justify 
carefully in the Menu Title field, then input Command+Option+K in the Keyboard field. 

Finally, click Add to add the shortcut to the Services menu. 



Chapter 11  AppleScript

11.1 About AppleScript

Jedit X supports AppleScript, and can be controlled by script editors and other external 

programs. You can also import scripts into Jedit X's context or Macro  menus to freely 
customize functionality. You may also control other AppleScript-compatible programs 
through these menus. 

Scripts can execute a wide array of functions within Jedit X, including (but not limited to) 
starting and quitting the program; opening, closing, and moving document windows; saving 
documents; and editing text by the word, paragraph, or document. 

For detailed information on the script classes and commands which Jedit X utilizes, select 
Help>Script Dictionary. The following window will appear:  

This manual only covers AppleScript as related to Jedit X, so see the following URLs or 
other introductory manuals for information about AppleScript as a whole. 

Using AppleScript 
http://www.apple.com/applescript/ 

AppleScript The Definitive Guide
 http://www.oreilly.com/catalog/applescpttdg/ 



 
Beginning AppleScript
 http://www.wrox.com/WileyCDA/WroxTitle/productCd-0764574000.html
 

Almost all Jedit X functionality may be accessed by AppleScript, but not all of it. Jedit X 
text actions are not recordable. 

11.2 Script Window

Once you register AppleScripts you have created in the Script window, you may activate 

them in a single step from the Macro  menu or the context menu. These menus have a 
hierarchical structure, so you can use and organize any number of scripts. You may also 
assign shortcut keys at will. 

To register a script, first save the script created in Script Editor to a script file. The Script 
Editor application lives in the AppleScript folder in Applications. 

Next, select Window>Script Window or   >Show Script Window in Jedit X to 
display the Script window: 



Click on the Macro Menu tab of the Script window to register scripts in the  menu or the 
Context Menu tab to register scripts in the context menu. 

Drag scripts to the desired location in the Script window to save them there. Then you will 
be asked which you want to copy the script files or the alias files.

These script files or alias files will automatically be saved in the following scripts folder.
 

~/Library/Application Support/Jedit X/scripts

Scripts may also be added with the  button on the bottom of the Script window. 

Pressing the   button , you will be asked whether you want to make a new script or fetch 



an existing script.

Pressing the "Fetch" button, you can add an existing script through the open panel.
Pressing the "New" button, a script name panel will appear.

Pressing the "OK" button, Script Editor will be automatically invoked and you can make 
new script in it.



Script order may be changed by dragging and dropping scripts within the Script window. 

Scripts may be deleted by selecting a script and either pressing the  button or the Delete 
key. 

Script names may be changed by double-clicking the script and then entering the new name. 

To alter a script itself, select it and then press the Edit button on the bottom of the Script 
window. Script Editor will open. 

To execute a script, select it and then press the Run button on the bottom of the Script 
window. 

To assign a shortcut key to a script, select it and then select Assign Shortcut from the 
Action menu. Shortcuts cannot be assigned to context menu items. 



To open the scripts folder in the Finder, select >Open 'scripts' Folder from the 
Action menu. 

To make and add a new script item to the list, select >New Script... from the Action 
menu. 

To insert a spacer after the current item, select >Spacer from the Action menu. 

To form multiple items into a hierarchical sub-group, select them while holding down Shift, 

then select >Group from the Action menu. There is no limit to the number of sub-
groups which can be created. 

To ungroup a group of items, select the group and then select >Ungroup from the 
Action menu. 

To form a new empty group, select >New Group from the Action menu. You may 
then drag and drop items to this group. 

To show all sub-groups in the Script window, select >Expand All from the Action 
menu.

To hide all sub-groups in the Script window, select >Collapse All from the Action 
menu.



Chapter 12 Automator Actions

12.1 What is Automator?

You can describe most of the text operations with AppleScript. But kind of knowledge and 
experience for programming is needed to use AppleScript, even though AppleScript is 
similar to English language.

Even if you are not familiar with programing, you can accomplish all of your time-
consuming, repetitive manual tasks quickly, efficiently and effortlessly with Automator*1 
Workflows. It’s simple to create custom Workflows just by dragging items, pointing and 
clicking. You can perform the task once using your Automator Workflow or many times.

 Actions are the building blocks for creating workflows. Jedit X supports 20 actions for file, 
find/replace, format and tools related operations.
 
 You can make various Automator Workflows in combination with actions of Jedit X and 
other application, such as Finder.

*1 Automator has been supported since Mac OS X 10.4 (Tiger). You can't use it on Mac 
OS X 10.3 or earlier.

12.2 Making your first workflow

To quickly study outline of Automator, let's make a workflow "Convert to UTF8/LF" that 
convert the text encoding of a text file to UTF-8.
 
Making a Workflow

Open Automator, it is located in the Applications folder. You can also invoke it from Finder 
context menu Autometor > Create Workflow. (Refer to Automator Help menu for more 
information.)

A blank workflow appears. 



Click Finder in the Library list at the left side of the workflow window. You may need to 
click the disclosure triangle next to the Applications folder to show all the applications.

Drag the "Ask Finder Items" action from the Action list to the workflow area on the right 
side of the window. Or double-click the "Ask Finder Items" action.

Set a message  "Choose a file to convert"  in the field "Prompt:".

To open the selected file with Jedit X, drag the "Open Finder Items" action from the Action 
list to  the end of the workflow area. Choose "Jedit X" for the popup menu "Open with:".



The document needs to be converted to plain text if it were rich text.

Click Jedit X in the Library list at the left side of the workflow window. Drag the "Make 
Rich or Plain Text" action from the Action list to the end of the workflow area. Choose 
"Plain Text" for the popup menu "Make."

Drag the "Make Rich or Plain Text" action from the Action list to  the end of the workflow 
area. Choose "Unicode (UTF-8)" for the menu "Encoding:" and "Unix(LF)" for the menu 
"Line Endings:".



Finally drag the "Close Jedit X Document" action from the Action list to the end of  the 
workflow area. Choose "Yes" for the popup menu "Saving" and check the checkbox "Close 
only Frontmost Document."

Save the workflow

As the setting of the workflow finished, choose the menu File > Save to save the workflow. 



Set the file name to "Convert to UTF8/LF" and choose "Workflow" for File Format.

Run the workflow

Click "Run" button at the upper right side of the window to execute the workflow. 
A file dialog will appear.  Choose a text file you wish to convert the encoding to UTF-8/LF.

Press the "Choose" button then the file will be opened with Jedit X, the encoding will be 
changed to UTF-8/LF and the document will save back to the file.

Supporting  Drag & Drop

In order to support  drag and drop for opening the target file instead of a file dialog, 
remove the first action "Ask Finder Items" from the workflow. (Select the action you want 
to remove and choose the menu Edit > Delete or press the delete key.)

Choose the menu File > Save as and specify the format to "Application."



Then the workflow will saved as an application which icon is as below.

Drop a text file you want to convert onto the icon, then the encoding will be converted to 
UTF-8/LF.

12.3 Action Reference

Actions related File operation

New Jedit X Document
This action creates a new Jedit X document with the specified text
Input: (Text)
Result: (Text)

Set Contents of Jedit X Document
This action sets the frontmost Jedit X document to the text passed in from the previous 
action.
Requires: A document open in Jedit X
Input: (Text)
Result: (Text)

Get Text from Jedit X Document
Get text from front Jedit X document and pass it to the next action.
Note: Jedit X document window should have been opened first.
Input: None
Result: (Text)

Close Jedit X Document
Close Jedit X document windows
Input: (Anything)
Result: (Anything) returns input untouched



Save Jedit X Document
Save the Jedit X frontmost document.
Input: (Anything)
Options: If you wish to save the document to the different location, specify the path to 
save.
Result: (Anything) returns input untouched.

Print Jedit X Document
Print the Jedit X frontmost document.
Input: (Anything)
Result: (Anything) returns input untouched.

Actions related find / replace

Extract Text with Jedit X
Extracts the strings from the Jedit X document that match the specified regular 
expression and returns the result as text list or single text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text or Text List

Replace Text with Jedit X
Replaces specified strings in the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text)

Actions related Format

Make Rich or Plain Text
Make the frontmost Jedit X document to Rich or Plain Text.
Input: (Anything)
Result: (Anything) returns input untouched

Change Text Encoding
Change text encoding and line endings of the frontmost Jedit X document.
Note: This works only for the plain text documents.
Input: (Anything)
Result: (Anything) returns input untouched

Actions related Tools

Remove Line Breaks
Removes LF's and prefixes from the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text

Hard Wrap Lines
Hard wrap lines with LF for the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text



Remove Prefixes
Removes prefixes from the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text

Add Prefixes
Adds prefixes to the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text

Sort with Jedit X
Sorts the paragraphs in the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text

Remove Duplicate Lines
Removes the neighboring duplicate paragraphs in the Jedit X document and returns 
the result text.
Note: Usually this action will be applied after the sort operation.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text
Related Actions: Sort with Jedit X

Process White Spaces
Processes white spaces in the Jedit X document and returns the result text.
Input: (Text) Input text or the contents of the frontmost document
Result: (Text) Single Text

Convert Full↔Half Width Characters
Converts the Full/Half width characters in the Jedit X document and returns the result 
as single text.
Input: (Text) text input or the contents of the frontmost document
Result: (Text) Single Text

Change Case with Jedit X
Change case for Jedit X document and returns the result as single text.
Input: (Text) text input or the contents of the frontmost document
Result: (Text) Single Text

Convert Kanji Kana with Jedit X
Converts Kanji to Hiragana or Hiragana↔Kanatana in the Jedit X document and 
returns the result as single text.
Input: (Text) text input or the contents of the frontmost document
Result: (Text) Single Text
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